Newbie looking for a little help to get started... Boss Katana and Ardour

Hi folks i’m new here, won’t bore you with the details but i’m trying to get back into learning guitar (properly this time) so got a Boss Katana 50 Amp.

I’ve installed Ardour, hoping to get to grips with it so i can use it essentially to record backing tracks etc.
I’ve been using unix for a long time but i’m new to any audio stuff including Jack/Alsa/Ardour etc.

I read that from Kernel 5.Xish onwards the boss Katana/USB audio is natively supported and i can confirm out the box that i can get Audio into the system (i can hear the terrible sounds from my guitar).

I’m not sure how to get Ardour to pick it up though, can someone point me in the right direction? Do i need to use JACK to “connect” it through to Ardour?

Any help greatly appreciated! Thanks!

I realise that my first post probably doesn’t contain a whole lot of information. So i figured i would provide a bit more here. Maybe this thread can help others with the same problem (not that i have a problem clearly i just don’t know what i’m doing).

Steps so far:

  1. Opened the JACK GUI qjackctl, and setup the settings as shown:

You can see that the KATANA is picked up as an interface

Apparently since i’m a new user, i can only post one image per post…

So then:
2. I started Ardour. Ardour detects that JACK is running and offers to connect to it using the current settings.
I then get a message saying that Ardour couldn’t create a session under the directory i specified.
After some googling, i found that this is possibly because JACK isn’t running in “real time scheduling” mode and it probably can’t allocate the required memory.
This source JACK Real Time Scheduling shows how to set it up and when restarting JACK i get no error messages anymore.
Ardour can open a session by connecting to JACK.

  1. And this is where i’m currently at.
    In Ardour i can add a new track and i can hear the guitar, and the “level” bar on the track reacts to the guitar’s input but Ardour can’t seem to record anything.
    I clicked show editor mixer and tried all the different input channels but all are the same.

I mean it makes sense when i look at the “connections” in JACK:

There are no connections to the Katana

The Katana is listed under ALSA and looks like the following:

Anyway, maybe i’m not understanding something properly or doing something daft, can anyone help?

Thanks again!

So you’ve record-arm the track, then enabled global record and pressed play? Does the transport start moving?

It looks like you’ve connected Master out (main output) to the track’s input. This causes a feedback loop.
The “Feedback” indicator in Ardour’s main GUI should be blinking (and Ardour will remain silent to prevent audible feedback). Breaking this connection should fix things.

Also the LTC ports should not be connected to each other. In particular break LTC-out -> LTC-in. The Metronome Click -> master connection is unusual, in particular since it’s also directly connected to playback ports.

I suggest to start a new session, and leave connections alone. The defaults should be fine.

Is there a reason why you use JACK? I’m asking since, In general it is recommend to use Ardour without it, especially if you need MIDI. It’s much easier to set up, can perform better too.

1 Like

Thanks for the reply.

Yes so i click record on the track, hit play and “make noise” on the guitar. The transport bar starts moving but the box stays blank.

I did see the feedback button flashing at one point. I’ve since killed everything and restarted and it is no longer doing that. I haven’t modified any connections in Jack, but i did try to select all different available inputs for my track in Ardour. The connections in jack currently look like this:

Honestly, i’m not sure! I had read that Ardour had to use JACK. I’ve since tried to use it by opening Ardour and setting it to use ALSA. It sees the Katana as an input device (and will only allow the Katana as an output device) but i get the same results - no recording)

Have you also enabled recording globally (rec button just right of the main play button)?

Maybe compare to

That looks better. The first input should be recorded.

It looks like you’ve made some additional direct connections to ardour’s master-bus (input 2 and 4 are patched though). You would hear them but they won’t be recorded. Was that intentional?

Nothing is intentional! :slight_smile:
Ok so i feel a bit daft, it seems that i wasn’t using the global arm as well as the track arm. I must have missed that in the tutorial i was following!

However, not quite success yet… The transport bar moves and a waveform is recorded but the waveform is tiny (can barely see it) and i can’t hear anything out of my monitor speakers connected to the PC. Any thoughts?

So i feel like i’m getting a bit closer. I can record but i can’t play back or monitor while recording, and (maybe this isn’t an issue) the visual waveform i see when recording is really small, i can’t really make it out.
So i think i have 2 things to solve:

  1. Playback/Output to PC monitor speakers.
    I’ve been playing around with the connections in JACK and i think i’ve ultimately come to the conclusion that the Katana amplifier USB audio interface is seen as a 4 channel input/output. I can record from each channel and i can playback back out of the amplifier. However, these 4 channels are the only system outputs i can see in JACK:

So it seems as though the onboard soundcard can’t be seen by JACK, i’m not sure how to resolve that.

  1. The “visual” aspect of the waveform.
    As i said, the recorded waveform is very small and difficult to make out, i’ll post a screen shot in the next post (new user limits of 1 per post). You should be able to see the level of the incoming signal seems high enough but i still get a small waveform.

Thanks again and regards!

As i mentioned above, here is a screenshot of recording, the level seems ok (i think?) but the resulting waveform is pretty small.

OK! so i think i’ve resolved the first problem!
I needed to use “alsa_out” to create a connection in JACK for my soundcard. For anyone else reading this: list the sound devices capable of recording:
arecord -l
And then create a connection for jack using:
alsa out -d hw:0,0
Where hw:0,0 is <card_number>, <device_number>

So i can record and monitor (there seems to be a delay - latency? And i can playback now.
Though when i playback its quite quiet, related to problem number 2?

You are thrashing around wildly in the dark! :slight_smile:

Thus far, it seems to be totally unclear what your actual goal is. Ardour is going to do recording and playback. Which device do you want to use for each of these tasks? That is, which device do you plan to send input to Ardour with, and which device do you plan to listen to?

1 Like

I certainly am! I started this thread because I was under the (wrong) impression that my issue was with Ardour itself or at least the usage of it. However it has turned out my problems are to do with the environment surrounding Ardour or more accurately my understanding of the environment.

Apologies if I’m using the wrong terminology or getting mixed up.

Ultimately I’d like to record from my amp into Ardour and then to be able to edit and playback from within Ardour. I think I’ve functionally achieved that but I still think I’m missing something. The recording is very quiet and while recording the waveforms are visually very small.

Anyway I’m enjoying the journey.

To make the waveforms more visible, change the waveform display in preferences to logarithmic: “Edit | Preferences | Appearance | Editor | Waveforms | Waveform shape”.

Hi, I guess you just need to normalize your track to get the intended result (region menu/gain/normalise). I usually normalize at - 10dB.

Ps: you have a patch panel very user friendly in Ardour. I am not sure if you see any benefit in using Jack to patch your ins and outs (see ardour manual: mixer strip). If you just use Alsa instead of jack and Ardour patch panel your work flow will be much easier.


I do not remember, does Ardour 5.12 include the equivalent of zita-ajbridge? The original post will need that feature to use two different audio interfaces (guitar amp for input, and laptop audio for output).

Note for amblikai, zita-ajbridge, i.e. zita alsa to jack bridge, is a higher quality replacement for alsa_out (and the alsa_in equivalent for inputs). It works essentially the same as alsa_out but with higher quality and more stable latency, so the zita version is recommended.

With jack you can definitely use a different device for input than for output. You cannot use two soundcards for input and likewise with output.
As far as as zita being high quality… do you have sources? I have never heard that before, and I’m very interested.

Finally, @amblikai , with ALSA the inputs will have an input gain parameter that you can access via alsa in the terminal or whichever ALSA-UI. Is there an equivalent in jack?

Only by loading a resampling jack client like alsa_in or zita-aj or zita-ja. The core of jackd must use a single clock, which typically means single device unless you explicitly have a device which allows synchronizing with a different device (typically via wordclock or similar).

You can using alsa_in, alsa_out, zita-a2j, or zita-j2a. One sound card must be the master backend device which will drive the jackd period clock, the other will be resampled.

Quality in this case being stable latency. This paper describes the design of zita-ajbridge, I don’t think it has the graph I was thinking of which shows how alsa_in and alsa_out latency can vary relatively drastically.

There are some quality comparisons here. See slide 4 (page 5 of the PDF):

Note the much higher phase noise floor of alsa_out compared to zita-j2a.

I assume you are referring to alsamixer, which would expose any hardware controls. Not every hardware device would have gain that can be adjusted from the ALSA driver, some have hardware controls only.
There are no gain controls in jackd, the design is a router only, any gain adjustment would need to be performed in a jack client.
Ardour has gain trims at the top of each channel, that would be the appropriate place to adjust gain if needed.


I appreciate all that. It’s late now, but I hope to get to reading those articles tomorrow. As far as “ever hardware device would have gain…” I agree, but I think its worth looking into. The OP does seem to be getting very quiet levels. We could adjust the trim at the DAW, but without addressing the gain at the soundcard they may be sacrificing SNR.