New user and Focusrite Scarlet 2i2 with Ardour

Hello All,

I am a new user to Ardour and wanted to share something to start with.

Basics: I have a Gigabyte EP45UD3R motherboard, 8 gigs memory, ATI4870 graphics card,
Dual core processor, E6600, can’t remember. I boot onto a old 160 gig experimental drive with grub/Ubuntu 11.10
I have Windows 7 64 on another drive. I installed Ardour the other day. I am also new to DAWs so I am a noob
in that respect.

Ardour first pass:
I installed, no problem and tried to use it with my USB Scarlett 2i2 Focusrite. I have 2 monitors hooked to the rear outputs of the 2i2. I tried to record a single track with my guitar plugged straight into the 2i2. I chose USB as the interface whn opening a new project and let the defaults stay as is. There were two USB choices but all it said was USB nothing else to differentiate between them.
No matter what I changed I could not get a signal to track one even with record enabled. I tried everything I could think of.
I got up the next morning and all of a sudden I though of one thing. I disconnected my USB Mic/Headset restarted Ardour and bingo we have plenty of signal. I adjusted the Scarlett inputs and recorder two different tacks one panned full left and one track2 centered L/R. I played for 2 minutes and listened to the garbage I produced. Here is where I got real interested.

I had been messing with Reaper on my Windows 7 64 setup. I know how to strip windows down and ended up with only 36 processes running, got rid of the visual candy and setup for a DAW inline with what Pro Tools recommends. I even recorder to a separate hard drive as PTools suggests.
No matter what I did in Reaper with the latest USB drivers for the Scarlett installed I still got pops and clicks.
So I boot into Ardour record onto the same old EIDE hard drive that Ubuntu 11.1 and Ardour are on, play back the result (no plugins).

Guess what? No clicks, pops, noise, nothing. Tracks that are so clean it totally revealed my lousy playing and timing. I wasn’t distracted by the noise and stuff so I could just listen to the results.

I’m Impressed. Now this is the lowest level of testing Ardour and I understand that, but just this initial experience has surprised me very much. I am looking forward to learning and working with Ardour.

If this helps someone else then good. I am impressed with the ease of install, function, and visual look of Ardour.
Very Very Cool Product.
Best Regards to all.

Its great that the Scarlett 2i2 worked for you. I’d advise you to read the Ardour floss guide listed on the “Support” page if you have not already. The reason had to unplug your USB headset to get it to work is because the Jack sound server will only work with one device at a time (well, it can work with more than one device with some advanced setup). From the Focusrite web page it is not clear that the Scarlett uses the USB2 audio standard (which should be supported in Linux). Can you get the Scarlett to work at 88.2 or 96 kHz? If so I think this would mean that it is really using USB2 and not just some USB1 compatibility mode. It is always good to find more devices which work in Linux. Since you are using Ubuntu I’d suggest looking into the kxstudio repositories which would significantly enhance your audio capabilities

Thank you for the information you provided.
I have emailled the Technal Support people at Focusrite to see if they would let me know the design specification of their USB drivers. Just a shot in the dark that they may answer the question.

I am looking at the documents you referred me to and am reading up on Jack.
I installed AV Linux 5.0.2 to see how that works.

I was able to get some recording done in Ardour and I will see if I can figure out if the Scarlett will work with the 88.2 or 96 KHz.
I will try and contribute in a small way what I can. With no DAW experience I can only offer a little at the moment.
Thanks for the tips and references.

Hi guys!

I’m looking at setting up an Ubuntu-based DAW, so I’m trying to get some recommendations for reliable hardware. I came across this thread after some Googling.

I’m prepared for a bit of geekery to get things working, but I’m mostly interested in making music with the scant time I have available!

So… Paul - can you back that statement up with a few examples that actually do work? I’ve spent hours trying to find some definite answers on this, but all I’ve really found has been people’s problems and glitches, and claims that things “should work”. That’s not really much of an incentive to part with cash and invest precious time.

If anyone here can offer me something a little more concrete I’d be much obliged!!!


@fernesto: “t IS important since almost no USB 2.0 audio interface works on linux, and those that work are all discontinued” - this isn’t true.

1 Like

Hi all

The good news to firewireless - express cardless laptop users is that the USB 2.0 Scarlett 18i6 interface from Focusrite seems to have some kind of support and a user had success making it work partially.

Check this out:

it IS important since almost no USB 2.0 audio interface works on linux, and those that work are all discontinued, and it is a 18 input channel interface so lets hope there is some improvement in this area over the next months…

Greetings!!! Hope you people are doing fine!

I sent MS Windows to my past life… I am an amateur music producer, and all my gear, is designed for to work with Windows ( obviously )Focusrite Scarlet 2i2 is my interface, and I also have an M-AUDIO Axiom air 32 mini midi keyboard. I have been trying to make both of my gadjets work with Ardour, without success. No sound, no midi inputs. Any ideas on how to solve my incident?

I am new to Ubuntu, Linux, but seems like I am managing to get used to it fast. Learning fast. Thanks in advance!

Ibexcapra: in general, most of find it extremely frustrating and slow to try to provide support to people via web forums. We prefer IRC so that we can talk to you in realtime. The support page ( has details on how to get onto IRC. It doesn’t work so well if you happen to be in a timezone very far from most people on IRC (typically european central to US mountain time), but even then it is still sometimes the best.

@Franklin Russell

Actually your statement that they don’t support Linux is slightly incorrect. They won’t support the Linux drivers, however IIRC they were one of the manufacturers the supported the development of the FFADO driver by sending them units to use for testing, etc. And unlike other manufacturers are not openly hostile and at least have been open to the concept.

Does that mean they will provide support for the drivers? Nope, but they have done more than some manufacturers at least to get their interfaces onto Linux.


got a new focusrite 2i2 as of yet my computer won’t see it seems like focusrite needs me to activate it on line from windows. I’ll keep trying though . I have a 18i 20 in use with KX-studio on my big computer works great. I did boot it up via windows though and downloaded their driver program to activate spdif and other things so I’ll have to try it out in windows which I don’t like doing . It’s usb 2.0 so it should work. Computer does not see it …
Focusrite does not support linux and they absolutely should. I told them about kx-studio and the success i’ve had with it. They were stocked but still no linux drivers for these babies yet.