New pc, new linux mint install, new ardour install....can't record from USB mic

Hi,

I was really hoping opening up my master ardour file on my new PC would have everything working…but no…I’ve been thru my previous posts trying to recreate whatever I did to make it work on my previous PC, but no luck.

Can anyone help?
Basically at this point I have no recording and no playback so I can’t do anything at all…

Here are some of my settings:
Ardour 6.7.0 (just installed)

Screenshot from 2021-07-05 05-34-24
Screenshot from 2021-07-05 05-34-36
Screenshot from 2021-07-05 05-34-46
Screenshot from 2021-07-05 05-35-05
Screenshot from 2021-07-05 05-35-50

More broadly, Ardour is wonderful once it’s working but for a non-techie user like me who just wants to record and edit a podcast getting it set up is a bit confusing…perhaps this isn’t feasible for technical reasons, but if there was some kind of wizard that would set up to record that would probably save people like me a lot of headscratching…

Anyway, thanks for any help, sorry to be so clueless…

Output device : HDA Nvidia ?

That sounds like Ardour is playing to you display (HDMI), is that what you expect?

Also check with alsamixer (then <F6> to select the soundcard, <F5> to show all controls), perhaps the mixer mutes input or output.

Thanks for the reply!

Ok one problem solved, thank you!

Output Device> Samson Q2U Microphone - I have sound! I can hear the music in my music track (in my master file), yaaay!

Still no mic input tho, here’s some screenshots of alsamixer (which I had forgotten all about)

thanks for any further help!
Screenshot from 2021-07-05 06-00-20

OK, so you have “HDA Intel PCH” (onboard soundcard), the NVidia and the USB Mic.
Setup looks correct now.

Back to the Ardour screenshot. The vocal track as no monitoring set neither “In” or “Disk” button is highlighted.

Press “In” and you should hear the input. Ardour does that automatically when you pick “software monitoring” (the default). Perhaps you’ve selected “hardware monitoring” in the new-user dialog? Check Preferences > Monitoring > Record monitoring handled by: ardour.

Also start a new session. The routing in the current one seems to be messed up. You probably connected some track outputs back to track-inputs. Feedback indicator is lit, so Ardour remains silent.

ok thanks for your help, I gotta get ready for my workday now but I’ll come back to this later or tomorrow morning!

Ok I’ve got it working, yaay!

You’re right my original session doesn’t work, but opening a new session works fine, luckily my master session isn’t particularly complex so I can easily set it up again.

Thanks for the help, much appreciated!