New note tupling feature added to version 8.2

I apologize if I am doing something incorrectly but I saw that there is a new MIDI feature available called “note tupling” that was added to the most recent version of Ardour 8.2.0

It says that you can hit “s” when specific notes are selected and that it will slice the midi notes based on the grid. “Shift+s” is said to reverse and “j” joins selected midi notes.
For some reason none of these hotkeys work for me, is there some kind of mode you have to enter before being able to achieve this new feature?
I also noticed a couple strange times when I hit the “j” key where it altered the midi region itself instead of the notes within it. As mentioned I might not be using this correctly though.

Thank You

If anyone else experiences this in the future.
I had used older versions of Ardour 8.x before and in my .config/Ardour8 folder had the following two files “ardour.keys” & “ardour.keys.old”, I removed them both and now this Note Tupling feature works. Apparently if you assign any custom hotkeys to older versions of Ardour, such as 8.0 & 8.1 (in this case) then these files have to be removed manually and you have to re-create new custom shortcuts with each new version install. These .key files get generated in your .config/Ardour8 folder when any custom hotkeys are assigned.
Hopefully someone in the future will find this helpful

You must be in internal edit mode (“e”) as is true for all MIDI editing operations.

Hey Paul, thank you for the response.
That is the mode I have been testing with, but don’t see anything occurring when I hit the hotkeys such as “s”
I am in the “e” edit mode and I select a long midi note and I hit the “s” key.
The note seems to stay the same length.

Also if I draw two midi notes side by side and I select them both and hit the “j” key that is when it seems to modify the actual midi region box (that I mentioned in post above), where the entire region box gets shortened and one of the two midi notes within it gets deleted.
When I drag and expand the midi region to larger size again those notes are still there they don’t actually get deleted.

If I can be of any help testing, no problem just let me know.
Thank You

Also using Linux Debian based distro with Ardour version 8.2.0 if this helps

Just tested it here. Works entirely as intended and described. (Also works in draw mode, FWIW). No idea why it is not working for you. Double check the version?

I edited my reply above also if interested.

Ardour 8.2.0
“Tracks and Traces”
(rev 8.2)

Any other users experiencing anything like what I have described?

Consider checking ~/.config/ardour8 to see if you have any .keys or .bindings files there which may represent your own custom shortcuts.

We have no mechanism for adding new shortcuts when a user has done this.

No, if I understand what you are saying, this is a fresh install of Ardour 8.2.0 and I have not modified any shortcuts yet.
I tried the “j” when selecting two notes in the “d” draw mode as well and it does the same thing as it does when in the “e” edit mode, it cuts the left side of the region box. If I then increase the size of the region box those notes show up again, even though they appeared to be removed.

Alright well I guess we will have to wait and see if any other users can replicate something like what I am experiencing.
As mentioned if you need any help testing or trying anything just let me know.
I apologize if I am doing something incorrectly.
Thank You

I have had version 8.0 and 8.1 installed before (although not installed now), I have not modified shortcuts in any version as of yet but would their shortcut keys still be in the Ardour .config folder?
There is an “ardour.keys” & an “ardour.keys.old” in this folder but again I have never modified any shortcuts.

Ahhh okay that is what it was, I just removed both of the two files I just mentioned above out of the config folder and now it works.
But wouldn’t this mean that everyone that has had older versions of 8.x would experience the same thing I am? unless they know to remove these files?

Those files are only created if you modify shortcuts (whether you think you did or not).

But even if I did, they would be from older version of Ardour 8.0 / 8.1 though.
Will removing these two .keys files cause any issues?

Major versions are always considered equivalent for this purpose (and we try to ensure that is true).

I apologize I am not sure if I follow what was just said.

I think I did change two hotkeys in 8.0
But even if I did, they would be from older version of Ardour 8.0 / 8.1 though.
Wouldn’t everyone using Ardour experience this issue then if they made any custom shortcut adjustments?

Also will removing these two .keys files cause any issues?
I will try it but, if I change a hotkey in 8.2 will a new .key file be generated in my .config folder?

Thank You

Yes, this issue always if you modify shortcuts: you will never get the modifications/additions that we make with a release. We have no mechanism to merge “your changes” with “our changes”.

Removing those files just gets rid of your own shortcut modifications, until you modify them again.

Oh, okay so that would mean then that with each release installed, that users cannot re-use their custom shortcuts, they have to re-create new custom shortcut files for each new version because you guys may have added new ones.
Okay so when modifiy any keys those .keys files get generated.
Overall good to know, thank you for your time.
While we have been ping ponging back and forth I have been playing with the Note Tupling, pretty cool so far :slight_smile:
Thanks again

I added a SOLVED section at the bottom of my original post for any users who might come across this issue in the future.

Keep in mind that I don’t know what I am talking about, but what if a user was for some reason using two different of versions of say Ardour on their machine, they would be sharing this same .keys file.
Not to say anyone should be doing this, but say for testing purposes.
Anyways that is not important, but the following might be.
If what I mention in the reply above this one is true, then would it be more beneficial to add version numbers to the .keys files that get generated by default?
This way if user has “ardour8.0.0.keys” in their .config/Ardour8 folder and then they install Ardour 8.2.0 then that old .keys file will cause no issue, because 8.2.0 version will be looking for a “ardour8.2.0.keys” file, if that makes sense.
Anyways hopefully this will be helpful
Thanks again for your help

we don’t differentiate between minor versions for the purposes of loading key bindings (“shortcuts”).

I understand, I was looking at this as if it was an ongoing issue that would occur, because I was viewing this like how other Linux programs use just the name of the program for its config folder. I forgot that due to the nature of how Ardour is created that you guys include the version number in the config folder name (example: Ardour7, Ardour8, etc.) so this issue will only occur in minor releases.

Thank You again for helping me fix this, couldn’t understand why these note tupling shortcuts were producing such odd results :slight_smile:

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.