New LV2 EQ Plugin avalible now!

Hi, I’m happy to anunce the new equalitzation plugin for ardour.
It is a LV2 plugin writed in C++.
It is very flexible, 10 bands and 12 filter types selectable for each band.
It have an intuitive GUI.
And… it is open source and free!

Get and try it now in:

Please send your feedback

I’m not sure I understand exactly how you are trying to use the eq - the one I was refering to (screenshot on the front page of my site) is a plugin for ardour, so it shouldn’t need to run using JACK. You should be able to unzip the file you download from the site, inside the zip file there will be a folder called ‘universal’ inside that there will be an x86 and an x86-64 folder. Choose one of these depending upon the CPU you have, x86 for 32Bit or x86-64 for 64Bit. Then from within that folder, copy the entire ‘graph-eq2.lv2’ folder to your LV2 plugins folder (normally at /usr/lib/lv2 or /usr/local/lib/lv2) - you may need root (admin) permissions to do this.

If none of this makes any sense, please use the ‘contact us’ link on my site to send me an email, and I’ll try and talk you through how to install it.

Hey Linuxdsp… sorry if I’m a bit of a novice with this question but I have been trying to use the eq you recommended but even after I run it with Jack i still cant get it to control the stream in ardour… what am I missing.


man that looks great. When im at home i’ll give it a try. It’s always great to see some new LV2 plugins appear.
Thx for posting…

will try it, tx.

thx for posting, really missing a good parametric eq with a nice curves gui.

however, i cannot use this one. i’ve unpacked the tarball, installed stuff mentioned in the install instructions and then installed the plugin itself. now it appears to be istalled correctly, i can see it in ardour’s plugin manager and i can insert it in the track, but after doubleclicking its name in the mixer’s plugin area just nothing happens - no gui pop-up, no sound change.

any ideas? running ubuntustudio karmic on amd64.


AWESOME! Looks good. I’ve wanted a good parametric EQ with a chart I can actually see, so I’ll test it out on one of my clients songs and see how it sounds.

EDIT: I successfully unpacked the tarball and installed necessary dependencies, built, and installed the plugin, It also shows up in the plugin manager and looks like it inserts into the track, but when I click on it, no GUI pops up, and no sound change. Not sure why this is happening, but I would very much like to test out this plugin, if someone can tell me how to fix it…


the development version of the LV2 CALF plugins contain nice parametric EQs (5, 8 and 10 bands I think).

Hi Sapista,

thanks for improving the Linux effects landscape :slight_smile:

Unfortunately I have the same problem as the people above. Compiled it on a 64bit Debian testing system. On double-clicking the effect, the console says:

Unable to open UI library /usr/local/lib/lv2/paramEQ-Rafols.lv2/ ( Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden)

Translation of the last bit: ( Cannot open the shared-object-file: File or directory not found)


Additionally, do you recommend your EQ for mastering? I think Jamin is old and outdated, and your EQ looks a lot more flexible.


Jamin is “old and outdated”???

Jamin is a little outdated, I think (I had to use it to master an entire album, and I have found it somewhat lacking…). I plan on making a mastering template for ardour using bleeding edge CALF LV2 plugins with other linuxDSP and Invidia LV2 plugins plus Barry’s Maximiser.

About the problem.

Before proces with “make install” be careful to install all requiered dependecies (view README file)

tomas vtipil and tbonedude: Make finish successfuly? Please run Ardour from a console and post the output when try opening EQ10Q plugin.

Benjamin Scherrer: Have you installed PlotMM? It look like PlotMM is not properly set in your system. EQ10Q for mastering, yes can work very well, but EQ10Q is a Mono plugin coming soon I will release a Stereo version.

About PlotMM: PlotMM is a C++ library for draw curves. I used this because I don’t have time to implement a widget in gtkmm. PlotMM is only a provisional method.

Lots of thanks for yours feedbacks

yes, make finished successfully (otherwise i’d be unable to make install then, or am i wrong?) terminal says:

Unable to open UI library /usr/local/lib/lv2/paramEQ-Rafols.lv2/ ( cannot open shared object file: No such file or directory)

  • the same as in Benjamin Scherrer’s post. i’ll try to reinstall plotmm, there must be some glitch in my build. enyone happen to know about a plotmm .deb?


i have the same trouble here, but…
actually, the UI-window is opening, but it is only a tiny line, just some pixels wide and about one cm high.
please others, try to look at your ardour window, somewhere you (perhaps) will see this tiny line.
i am able to resize it, but than the ui-window is empty…
i also get this libplotmm error…it is now installed in /usr/local/lib…
no other ideas.

sapista - very much thanks for your work!


EDIT: now, since i run ‘updatedb’ and ‘ldconfig’ i get the following error:

Unable to open UI library /usr/local/lib/lv2/paramEQ-Rafols.lv2/ (/usr/local/lib/lv2/paramEQ-Rafols.lv2/ undefined symbol: _ZThn8_N6PlotMM4PlotD1Ev)

the ‘’ is exactly in the place the plugin is trying to open it, but obvousely it does not work.

After installing plotmm, make sure you have /usr/local/lib (or lib64 depending on where ‘make install’ puts it) in /etc/ and run ‘ldconfig’ to update the library cache

You can see if the cache contains the lib by running ‘ldconfig -p | grep plotmm’

It worked fine for me on Karmic 32bit, even if it took a while to understand the GUI.

tomas vtipil: Check your installation of PlotMM. First look if exist in your system (/usr/lib or /usr/local/lib). If you can compile and link EQ10Q but can’t execute its GUI probably PlotMM is broken in your system. There is not a .deb for PlotMM in debian repositories. I encourage you to download it ( and compile yourself is not dificult, I recomend set the installation path for plotmm to /usr for a Debian system (PREFIX = /usr).

heureka, got it runnin’!
just reinstalled plotmm (ie. did
make install

once more) and now it works! no idea what was wrong with the previous build, this one’s apparently ok.

just spent couple of minutes playing with eq10q, trying to use its various settings on a sax track. first impressions from the plugin:

functionality and sound: just fine. i was able to do everything i wanted and it sounded ok to me. good to have a/b switch, working bypass button and presets (belive or not, not quite common in lv2 world!). only thing i miss is exact value setting (ie. when trying to make 50 hz cut, i can have either 49.2 or 50.4, but not exactly 50. not that it would make such a difference, one just feels better setting it exactly, that’s what are parametric eqs made for…)

gui: the interface’s behavior is still sorta enigmatic to me - the points seem to be sometimes clickable/dragable, sometimes not. or are the points just too small to drag them with the mouse comfortably? when dragging just the numbers, everything works fine.

overall look and feel: well, this is pretty much a matter of personal taste - i would tend to make the graphics as simple and clean as possible, maybe avoid garlands and spirals and make bigger points/meters/buttons/value controls instead. i just like minimalist/functionalist design - don’t take this too serious please :slight_smile:

thanks for great work!

Once you’ve activated a band (clicked the ON button) and selected which type of EQ you want you can drag the point.

peder: yes, that’s how i expect it to work, but it seems it doesn’t work 100%. ie. i select the filter type and click the ON button and then i can drag the point. after releasing it i click somewhere else on the graph canavas, then try to drag the point again and it doesn’t work. i give it a couple of tries and it starts working. then i click firefox window to write this post, then go back and again, it doesn’t work instantly but takes some 3 attempts to be able to drag the point, and so on.