New hardware

Good morning. I am running Ardour on Ubuntu 10.04 Lucid Lynx. I have just finished making my first album onit, and I found that as the project files became more complex, my hardware was not quite up to the task, so I feel I need to upgrade my processor (currently an Intel i3 with onboard graphics). Obviously I will also need a new graphics card to accompany my intended Intel i7, and I wonder how powerful it needs to be the handle the screen redraws and waveform previews. Recommendations? My full current specs are:

Gigabyte GA-H55M-USB3 Motherboard Core i7 Socket 1156 Intel H55 Micro ATX RAID Gigabit Ethernet LAN

intel Core i3 530 2.93GHz Socket 1156 4MB L3 Retail Box Processor

G.SKill RipJaw 4GB (2x2GB) DDR3 PC3-12800 1600MHz CL8 Dual Chann

Samsung SH-S223L Internal SATA DVD-SM Drive With Lightscribe

Samsung HD103SJ SpinPoint F3 1TB 7200RPM SATA II 3GB/s 32MB Cach

Thanks very much!

Further to my above question, I have just located the hardware requirements page on this site, and I am now wondering if, as suggested, an Athlon CPU might be preferable. Any ideas if it will mesh with my motherboard? Failing this, is it likely that in Intel i5 would do the trick?

There is no possible way to anwer this question in general. Ardour does not require an advanced GPU - it does nothing in 3D at all, which where most of those devices focus their power. A good video card from 10 years ago (e.g. Matrox, who opted to concentrate on 2D and thus went out of business) can easily handle it. What you need on the video side is just a working, efficient video device driver. determining whether or not this is case is extremely hard to do without just trying it.

The rest of the your question is impossible to answer because whether or not a given system will work well for realtime low latency stuff depends on much lower level details that is ever disclosed in the spec list. Athlons are essentially out of data at this point. PhenomII processors offer the best bang for the buck (in dec 2012), but realtime low latency performance is not, ultimately, related to how fast your CPU is. my current system is much, much more powerful than the previous one was much better with real time performance.

You can’t use an AMD processor in a motherboard intended for an Intel, it won’t work sorry. What I would say first is to just try the A3 beta which is better suited to spread DSP out over multiple cores(A2 only did single cores) and see how much a difference that makes for you. Then I would look at hardware upgrades only if needed, but you may find that they aren’t needed.

At this point if I was going to do hardware upgrades like processor or memory, I would probably go all the way to a quad core i7 solution, combined with 8GB of RAM. As paul mentioned, graphics can be a tricky thing, but honestly you probably won’t get much better for Ardour than you are getting currently with the intel HD graphics. Now if you were running other very graphics intensive applications at the same time, or a compositing desktop, then we would be talking a different story.


Thanks guys! That’s really helpful, despite my impossible questions. Basically my perceived harware problems manifest themselves as ardour disappearing when I reframe the view of a complex project, and a large quantity of clicks and pops obscuring the audio the more I edit. Also it starts to forget about crossfades I have made, which is not helpful but not as common a problem. I’ll try and get Ardour 3 Beta up and running, and see how that does with my current gear. If that’s still no good, I’ll grab myself an i7 and a solid but affordable graphics card, and start mucking about with those. I can’t imagine needing 8 GB of RAM as I’m relatively old school with my production style, so I don’t go in too much for plug ins. But then, what do I know? Less than I’d like, I assure you.

I’m relatively old school with my production style, so I
don’t go in too much for plug ins.

Seems kind of surprising you are having problems at all then. How many tracks are you talking about? And how many edits per track, or how many total edits? An i3 running at nearly 3GHz is nothing to sneer at, plenty of people are doing a lot of work on processors which are a lot less powerful.

There were an awful lot of edits, as I was largely working with musicians who were unfamiliar with the material, so I recorded a lot and pieced it all together. I started to run into trouble when I got to about 29 fairly edited tracks. As for how many, I couldn’t tell you but I suspect it ran to thousands on some projects. On one song I got up to about 60 tracks (but it was only 20 seconds long, with not much editing). The biggest pain was an 8 minute song with 38 tracks. On that one, by the end I couldn’t really hear the audio for all the clicks, so the album only just got finished, and towards the end it really felt like the computer was collapsing under the strain. I am very keen to avoid this in future. I had a quick go at installing Ardour 3 last night but I was face with a plethora of error messages and it wouldn’t run. It might perhaps require some more time at the weekend, or in the new year. But if I have only been relying on a single core for both graphics and sound, I am not surprised the strain began to show on these excessive projects, and if Ardour 3 will solve this without my coughing up £400 on hardware for my next album, I will be a happy man.

suddentwigs: i’d like to see those error messages.

Paul - It would be really helpful if you could take a look. It’s probably quite mundane stuff to do with my general setup, but unfortunately it’s beyond my technical knowledge. If you could help me get it up and running, I’d be extremely grateful! I’ll try again and post the results in a little under 12 hours’ time.

Evening. I ran the Ardour 3 installer again, and this is the resulting output: Welcome to the Ardour installer

Ardour will be installed for user pea in /opt

Thu Dec 20 23:17:18 GMT 2012
Architecture is x86_64
Checking for required disk space
Unpacking bundle for x86_64
tar: Ardour_x86_64-3.0beta5_13072/share/patchfiles/*Super BassStation(bw).midnam: Cannot open: Invalid argument
tar: Ardour_x86_64-3.0beta5_13072/lib/clearlooks/engines/ Cannot create symlink to ../../': Operation not permitted tar: Ardour_x86_64-3.0beta5_13072/etc/fonts/conf.d/40-nonlatin.conf: Cannot create symlink to…/conf.avail/40-nonlatin.conf’: Operation not permitted
tar: Ardour_x86_64-3.0beta5_13072/etc/fonts/conf.d/80-delicious.conf: Cannot create symlink to ../conf.avail/80-delicious.conf': Operation not permitted tar: Ardour_x86_64-3.0beta5_13072/etc/fonts/conf.d/49-sansserif.conf: Cannot create symlink to…/conf.avail/49-sansserif.conf’: Operation not permitted
tar: Ardour_x86_64-3.0beta5_13072/etc/fonts/conf.d/60-latin.conf: Cannot create symlink to ../conf.avail/60-latin.conf': Operation not permitted tar: Ardour_x86_64-3.0beta5_13072/etc/fonts/conf.d/30-urw-aliases.conf: Cannot create symlink to…/conf.avail/30-urw-aliases.conf’: Operation not permitted
tar: Ardour_x86_64-3.0beta5_13072/etc/fonts/conf.d/50-user.conf: Cannot create symlink to ../conf.avail/50-user.conf': Operation not permitted tar: Ardour_x86_64-3.0beta5_13072/etc/fonts/conf.d/65-fonts-persian.conf: Cannot create symlink to…/conf.avail/65-fonts-persian.conf’: Operation not permitted
tar: Ardour_x86_64-3.0beta5_13072/etc/fonts/conf.d/20-fix-globaladvance.conf: Cannot create symlink to ../conf.avail/20-fix-globaladvance.conf': Operation not permitted tar: Ardour_x86_64-3.0beta5_13072/etc/fonts/conf.d/45-latin.conf: Cannot create symlink to…/conf.avail/45-latin.conf’: Operation not permitted
tar: Ardour_x86_64-3.0beta5_13072/etc/fonts/conf.d/51-local.conf: Cannot create symlink to ../conf.avail/51-local.conf': Operation not permitted tar: Ardour_x86_64-3.0beta5_13072/etc/fonts/conf.d/20-unhint-small-vera.conf: Cannot create symlink to…/conf.avail/20-unhint-small-vera.conf’: Operation not permitted
tar: Ardour_x86_64-3.0beta5_13072/etc/fonts/conf.d/30-metric-aliases.conf: Cannot create symlink to ../conf.avail/30-metric-aliases.conf': Operation not permitted tar: Ardour_x86_64-3.0beta5_13072/etc/fonts/conf.d/90-synthetic.conf: Cannot create symlink to…/conf.avail/90-synthetic.conf’: Operation not permitted
tar: Ardour_x86_64-3.0beta5_13072/etc/fonts/conf.d/69-unifont.conf: Cannot create symlink to ../conf.avail/69-unifont.conf': Operation not permitted tar: Ardour_x86_64-3.0beta5_13072/etc/fonts/conf.d/65-nonlatin.conf: Cannot create symlink to…/conf.avail/65-nonlatin.conf’: Operation not permitted
tar: Exiting with failure status due to previous errors

Checking system libs to see if they are compatible with Ardour.

Found existing Ardour installation.
Do you want to run the uninstaller /opt/ ? [y/n]: y

Running uninstaller /opt/
Thu Dec 20 23:17:47 GMT 2012

Removing existing Ardour installation at /opt/Ardour-3.0beta5_13072

Installing Ardour 3.0beta5 built from 13072 in /opt

Adding Ardour to the applications menu

Creating a desktop link for Ardour in /home/pea/Desktop
cp: cannot stat /opt/Ardour-3.0beta5_13072/share/Ardour-Ardour_3.0beta5.desktop': Permission denied chmod: cannot access/home/pea/Desktop/Ardour_3.0beta5.desktop’: No such file or directory

Copying uninstall script to /opt

Creating link Ardour3 in /usr/local/bin

Checking to see if Jack is installed

Jack OK
sh: /opt/Ardour-3.0beta5_13072/bin/sanityCheck: Permission denied

System failed the quick sanity check… Looking for the cause
sh: /opt/Ardour-3.0beta5_13072/bin/sanityCheck: Permission denied

System does not allow realtime for the current user… Looking for a solution
sh: /opt/Ardour-3.0beta5_13072/bin/sanityCheck: Permission denied

!!! WARNING !!! - The system does not seem to have an audio group (audio or jackuser).

We will not attempt to fix this. Please configure your system to allow
non-root users to execute realtime tasks.

Press ENTER to continue:
sh: /opt/Ardour-3.0beta5_13072/bin/sanityCheck: Permission denied

!!! WARNING !!! - Your system seems to use frequency scaling.
This can have a serious impact on audio latency. You have two choices:
(1) turn it off, e.g. by chosing the ‘performance’ governor.
(2) Use the HPET clocksource by passing “-c h” to JACK
(this second option only works on relatively recent computers)

Press ENTER to continue:
sh: /opt/Ardour-3.0beta5_13072/bin/sanityCheck: Permission denied

!!! WARNING !!! - You are not allowed to lock memory.

We will not attempt to fix this. Please configure your system to allow
non-root users to execute lock memory.

Press ENTER to continue:

Cleaning up

!!! Install Complete !!!

When I then attempt to run the program, I receive this message:

Could not launch ‘Ardour-3.0beta5’

Failed to execute child process “/opt/Ardour-3.0beta5_13072/bin/ardour3” (Permission denied)

All of this is a mystery to me. Please help if you can!

what linux distribution (and version) is this ?

It’s Ubuntu Studio 10.04.

this isn't trivially solvable by using a webforum - the medium is too slow. there is no clear reason for the errors you are seeing.

i respectfully ask that you show up on IRC (see for details. i'm on US Eastern time (GMT-5) daytime (typically somewhere between 07:00 and 22:00)

Good idea, I’ll be on tomorrow at some point, though when I am not sure. In the meantime I’ll try reinstalling the operating system, and maybe some slightly older Betas of Ardour 3. Thanks.

suddentwigs: please don’t use older betas. i will be in and out today on IRC, mostly due to various pre-xmas duties. my nick on IRC is “las”.

Okey doke, no older beta for me then. Regrettably not in my studio today but I’ll try and find you tomorrow to help me get it sorted. Cheers!

HI Paul,

I can confirm that when running with Hyperthreading enabled I do see "8 cores in Ardour 3 on a 4 core cpu…

With regards to comments on mechanical vs SSD disks… SSD disks give you the luxury of not needing to manage them… Having a dedicated disk for audio projects will minimise this, but does not completely remove fragmentation… I can definitely say since I moved to SSD, I only ever see xruns when I am trying to push ffado too hard or am running a lot of plugins. I typically run jackd at p64 n3 and then go up to p128…



ardour’s information on “number of cores” comes from sysconf(_SC_NPROCESSORS_ONLN); i don’t believe this differentiates that this counts hyperthreads but the interwebs are a litle confused on this point. we do it slightly differently on os x (and windows) but i believe that the numbers there also only count cores, not hyperthreads.

By the way, many early SSDs especially suffered from a performance related problem where once you wrote enough info to fill the disk (Not meaning the disk was full, but that you had written enough info over time, even if deleted) the disk would slow down tremendously. This was not true with SSDs that had decent controllers, and is less of an issue with modern SSDs is my understanding. So the short is, don’t go ultra cheap on your SSD and it will blow away the performance(Read or write) of any single mechanical disk most likely.


Don’t use git or svn for this.

My honest suggestion? Simply copy the directories over. If you are looking for a versioning type of system, rsnapshot or one of the alternatives works well, and provides a nice backup solution. This is exactly what I do at my work, however I don’t even both putting sessions on my local SSD, if your NAS is fast enough to saturate a gigabit ethernet link, you can use it to edit audio as well(I believe i tested even 128 track recordings IIRC at one point).