Need to convert some 24-bit, 48k sd2 files...

I need to convert some files recently recorded at a friend of mine’s studio. He isn’t much of a computer fellow, so all I have are copies of the original .sd2 files. Is it possible to convert them to an ardour-friendly file format? They are at 24-bit/48kHz…what would be the least damaging (in terms of fidelity) file format to convert them to? I’ve found a few command line applications, but figured I’d ask here before installing more software…

Thanks in advance.

Thanks, thorgal. I’m still having some issues, though…mainly, I’ve been trying to install the Perl File Converter app, with no success. I don’t think it’s compatible with my Ubuntu Studio distro (64 bit)…pacpl doesn’t even show up in Synaptic.

I’ve tried simply importing them as raw data via Audacity, and can tell my track is there, but it is still mostly unusable noise, even when all the bitrates/etc. match. It might be due to the ‘stem’ file being combined with the audio, but it’s beyond my meagre knowledge to write a parser for it. I’m hoping there is an easier way…

Hmm…is anyone currently maintaining sndfile-info, or a site discussing its usage? The only thing I could find by a quick search were some incomplete man pages…

sndfile-info is a part of the libsndfile package. its maintained by the same person who is the author of libsndfile, Erik de Castro-Lopez. i know that a new release of libsndfile is scheduled for the near future, but sndfile-info isn’t the issue here. sndfile-info, as i tried to explain, is simply a small utility built on top of libsndfile. there is also, for example, sndfile-play, another small utility. the problem you are facing is that libsndfile itself cannot handle your audio file. sndfile-info can’t be “maintained” or “fixed” to correct this.

Any uncompressed format is fine. You’re not going to lose any audio by converting to WAV or AIFF. I’m not sure how Linux deals with SD2s though - I know it’s not easy to open them in Windows because of the way the format works but if you’ve found software in Linux then go ahead and try it.

hey! you can start by reading this :
I would think libsndfile can handle this but YMMV :slight_smile:

Regarding the file format and sample format: If libsndfile can handle them (and I believe it can), you can just import them directly into Ardour. No other steps required. If you select the “copy imported files” option, Ardour will write new files in its own current native format (up to the user, but typically WAV). If you don’t, it will just read the files as is.

Regarding the sample rate: the simplest thing is to just run the session (and thus JACK) at 48kHz and not convert this at all. If you require running at a different rate, I’d suggest using libsamplerate’s utilities to take care of this, and pick its best conversion quality (you will not be able to hear the difference).

Please read and follow the advice I offered there, then report back.

libsndfile, which is the basis of sndfile-info and most of Ardour’s audio file handling, is the de-facto standard for handling audio files on Linux, and is portable to other platforms. you’d need to talk to its author or others with more expertise to make further progress on this issue. until sndfile-info (and thus libsndfile) can open your files correctly, Ardour will not.

Here’s the sndfile-info output:

Version : libsndfile-1.0.17

Error : Not able to open input file Drum Overheads2.L.sd2.
File : Drum Overheads2.L.sd2
Length : 1986982
Parse error : File contains data in an unknown format.

Supported file format but file is malformed.

At a guess, the issue would be that extra tag file. If that is the problem, well, how difficult would it be to parse it out? Is there an application out there I could easily use, keeping in mind that I have very little experience in Linux? I enjoy solving these sorts of issues, as it helps me to learn a bit more about the damn thing…

Gotcha. Excuse me. I’m still pretty new to all this…

It looks like I might be able to use libsndfile to open and save the file as a raw data wave, and simply delete the section of noise related to the data tag file. I’ll try it later and report how it goes…