***need help: trying to set up multiple soundcards in Jack

I followed the directions on the Jack page w/r/t setting up multiple soundcards for jack

I created an ~/.asoundrc file

I forgot that I needed to type in the name of the card which is “merge” and accidentally typed “merge” instead of “hw:merge” into the Jackctl panel

and now when I launch Jack Control the panel comes up, goes and stays dark

I tried to hack the ~/.jackdrc file (see below)
but I’m unable to get Jack Control working again

here is what’s contained (now) in the .jackdrc file:

/usr/bin/jackd -r -P80 -p128 -m -dalsa -dmerge -r44100 -p512 -n5 -D -s -m -i2 -o4 -Xseq

but I’m still unable to get Jack Control working

is there another file I should be tweaking instead? command line?

any help is appreciated!


AFAIK ~/.jackdrc is for jackd itself - not qjackctl.

Qjackctl’s config file is ~/.config/rncbc.org/QjackCtl.conf

@CLA: thanks for the filepath for the qjackctl file - I rebooted my machine and was able to get into the panel and change things back to normal… :slight_smile:

so…back to getting multiple cards working:

  • I’m attempting to get two iMics working - I know that the same type of card can pose problems…

  • I created and set up the ~/.asoundrc file as per the instructions on the Jack page as follows:

pcm.merge {
type multi;
slaves.a.pcm hw:0
slaves.a.channels 2;
slaves.b.pcm hw:1
slaves.b.channels 2;
bindings.0.slave a;
bindings.0.channel 0;
bindings.1.slave b;
bindings.1.channel 0;
bindings.2.slave a;
bindings.2.channel 1;
bindings.3.slave b;
bindings.3.channel 1;
ctl.merge {
type hw
card 0

  • I typed “hw:merge” into the Interface, Input and Output Device fields (and variations thereof)
  • Audio set to Duplex – and tried Playback too
  • set the number of input and output chs to 4
  • started Jack
  • Jack could not connect to server as client

error message:
14:39:28.438 Could not connect to JACK server as client. - Overall operation failed. - Unable to connect to server. Please check the messages window for more info.
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jack server is not running or cannot be started

  • any suggestions/tips/tricks are appreciated!