Need Help. Lot's 'O Issues!!!

I’m currently experiencing several issues with Ardour GTK2, JACK, and Jamin and am hoping to get some ideas as to where to start troubleshooting.

I’ll start with Ardour and the list my current issues:

  • Loss of sound for any region using CAPS plugins, especially "CAPS 10-band Analogue EQ" on re-opening of project
  • Loss of sound using Steve Harris "GATE," depending on the order of plugins.
  • Mixer "groups" don't always load appropriately. Have to check or uncheck to reactivate.

A workaround for the EQ is to use the Steve Harris “multiband EQ.” I’ve had better success with that plugin working reopening a project. As far as the GATE, it’s hit or miss. Sometimes, I just have to remove it and then re-add it.

JACK issues list:

  • Can't stop getting xruns

I know this is tied to latency and periods, but I can’t figure out the best solution. I have an AMD 5400+ on a state-of-the-art motherboard with integrated HD audio, 4GB DDR2, and a SATAII 250gb hard disk. I’m running Linux / Mepis 7.0. The best setting I can find with the least amount of xruns is:
Frames: 512
Sample Rate: 48000
Periods: 4
Port Max: 512
Timeout: 500

According to most documentation, I want my frames lower @ like 128 or even 64, but the xruns won’t allow such. Is there a way to tell what I should be using based on my system + audio specs?

Jamin issues list:

  • Sound is amplified and reverb'd WAAAAY too much.

I have the Ardour Master 1/2 OUT connecting to the Jamin IN, but man is the sound quality distorted and echo’y. It’s near impossible to Master a song with that happening. I have no idea where to begin on this subject. My workaround is just not to use it and use the Dyson Compressor on Ardour’s Master Post Fader. That tends to create a Reverb effect as well though.


I’ve had more success running various plugins in JackRack…although the CAPS plugins are still whacked (a shame, as they are otherwise some of the more useful ones for my kind of mixing). It makes for a more cumbersome setup, but that’s not much of an issue for me.

All the previous comments re: ‘get the quality before the mixing’ are seconded here. Turd-polishing sucks, and I have yet to hear a plugin compressor that sounds anything like as cool as even a $300.00 Really Nice Compressor, much less an LA-4 or an 1176. Cheap mic preamps (read as Behringer…the only ones I own, currently) definitely limit fidelity…I just recorded a bunch of tracks on a friend’s Soundcraft Ghost LE, and am now about ready to chuck my mixer into the nearest dumpster…

I had same kind of issues when i tried to use suse 10.0 without realtime capabilities.

  1. check out your
    /etc/security/limits.conf file

It should look similar to this:

@audio - rtprio 99
@audio - memlock 500000
@audio - nice -10

Add your user to the audio group.

  1. Start jack with realtime enabled, easiest with qjackctl, just click the realtime box.

  2. Jamin echo, could be a problem of multiple outs : maybe you are sending your master both to jamin and system, resulting duoble output with “latency echo”.

Thanks for the reply. I don’t have anything like that in my “limits.conf” file. In fact, what lines that are in there are all commented out “#” (I’m guessing they are all examples). Should I add what you posted?

I am using qjackqtl, but the message logs keeps telling me realtime isn’t supported.

I think you’re right about the Jamin echo/reverb. I just read another article about how to use “insert 1” plugin to connect/use Jamin on the Master Post Fader and it seems to be a better solution compared to what I was doing (simply connecting MASTER outs to JAMIN ins, and then connecting JAMIN OUTS to a new Stereo track to record).

Hi hippie,

I used to use MEPIS, you probably would benefit with a realtime kernel, I know there is a thread in the packages and scripts forum at MEPISlovers where I requested a realtime kernel and “Stevo” did one up, unfortunately my mobo wouldn’t allow me to install MEPIS.

Here’s a link to that package:

Also the CAPS 10 band analogue EQ is really buggy, I’d avoid it at all costs!

Jamin’ works OK depending on what CVS you are running, I find some EQing and the “Satan Maximizer” can also give decent results for mastering, but that is a matter of opinion of course.

Haha… I knew somehow Stevo would be involved!!! So… how come the mobo/Mepis combo won’t work? I had a ton of issues myself awhile ago, but got them worked out. Stevo can fix anything!!!

Anyway… good to hear it’s not just me experiencing issues with some of the CAPS plugins. The TAPS plugins have issues too, but they don’t seem as drastic. Satan Maximizer and some EQ… eh? If I can keep all the mixing/mastering in Ardour, that would be awesome. Most web articles seem to be using other software though, so there’s no good articles telling me what to use and how in Ardour alone for mastering.

Know of any websites with examples/screenshots of what plugins were used on what instruments? The Ardour website screenshots had some examples (mono to stereo, SC4, Multiband EQ,), but I don’t know if those were actually legit, or just there for the sake of making the screenshots.

Hi Again,

My install issue with MEPIS was a mixture of SATA and PATA drives, I also had a problem with Ubuntu Hardy as well…

Well as you know all this plug-in discussion is very subjective, since I came to Ardour after 10+ years of a Windows (Cubase) based DAW I prefer to compile Ardour from source with VST plugin support and after MUCH trial and error have a very stable setup of LADSPA and about 35 or so VST plug-ins.

I agree there isn’t a whole lot of info on using LADSPA plug-ins out there.

FWIW here’s some I’ve found to be quite good:

Mono to Stereo
SC4 Compressor
CAPS Plate
Satan Maximizer
TAP Reverberator
FIL Parametric EQ

Not to keep beating a dead horse, but can you break down which plugin you use for what instrument? Like the Vynil plugin? What instrument/track would you want to add “aging” to? The Tap Reverberator… guitars or vox? Sorry for all the questions!!!


Ask 6 different musicians their workflow and expect 6 different answers…and they will all have merit.

As a rule I try to use the right mic for each instrument so I can avoid unnecessary EQing and such so…Condenser mics for Vocals, Acoustic Instruments and Over top of the drumkit, Dynamic Mics for Amped Guitars, Bass and individual Drums.

On Vocals I find the SC4 Compressor and TAP Reverberator to work pretty well, Freeverb3 can also sound nice but it is a little bright for my taste. I prefer my VST EQ’s (ParisEQ & Kjaerhus Graphic)so I am not the best to comment on LADSPA ones.

For Drums I really like the CAPS Plate Reverb, very warm and dark like classic studio plates. Also the DJ EQ is quick and simple for non-surgical EQing

For Guitars it depends on the tune, I try to get a good sound out of the amp first, sometimes that it, Sometimes I will use the SimulAnalog Guitar Suite but it is also VST…Supposedly the TAP Tubewarmth plug-ins work nice at Amp simulation, I haven’t really delved into that myself

For keyboards I use QSynth with a hand-rolled bunch of my own Soundfonts with Hammond Organ, Wurlitzer and Rhodes Electric Pianos etc, It integrates very nicely with Ardour and Jack.

For mastering I usually run an EQ and Satan Maximizer on my Master Bus so I can tweak the whole mix through the Master bus, The Satan Maximizer is simple to operate, Decrease the bottom slider until it sounds bad! When I’m ready to export I move my “start” and “end” markers in tight to the beginning and end and export. If there are trimming and fades needed I do them in Audacity.

I think Vynil sounds really authentic but I don’t really ever use it, well not yet anyway.

Of course different styles of music will necessitate different workflows, this is just what works for me. I hope that at least answers some of your questions.

I’m sure there are many more experienced users here who can comment further

Yes, you should add the lines to your /etc/security/limits.conf file and make sure your user is part of the audio group. I do not know if that is enough in MEPIS to enable realtime ( it is in opensuse 10.3 at least), but you should be able to start jack with realtime. If not, you need to install the realtime kernel , link posted by GMaq.

I tried adding those three lines first, but don’t think that did the trick. I then proceded to install the RTC Kernel, and well… I’m not sure what all happened with that. I found the thread on the Mepis forums, and did as the instructions said, but when I rebooted to the RTC Kernel, my PC ran like crap. RealTime didn’t work in Jack and the windows would slowly pane across the screen. It was like running VISTA on a PII. I’ll hit up the folks on Mepis to see if there’s other things to try.


If you downloaded the package with the RTC Kernel then you should have all the related modules in the package as well, If you install the Kernel only without the others it would quite possible make your system act weird because the new kernel is not playing nice with your existing modules.