Need a little help

Hello all. I’m a little frustrated with trying to set this up. I’m trying to setup realtime scheduling with a normal user but whatever I do it won’t work. It will work with root but not a normal user. The error is ‘real-time scheduling: Operation not permitted’. I’m using a newly built LinuxFromScratch and BeyondLinuxFrom Scratch system with kernel 3.8.8 and everything I apparently need to get realtime audio. I’ve tried configuring /etc/security/limits.d/audio.conf, I’ve tried disabling RT_SCHED_GROUP in the kernel config and other things but still can’t get realtime to work. Also can’t seem to change the memlock number. After setting it to ‘unlimited’ in the /etc/security/limits.d/audio.conf file I still get ‘64’ with the ‘ulimit -l’ command. This is really frustrating as with my Linux Mint 14 system I don’t have to go through all this. Not sure if I’m missing a configure option with one of my source audio builds but nothing seems to work. All packages are built from source if that helps.

Ok well it seems solved the rtprio and memlock issue. I’m using SLIM as my display manager and I had to reinstall it with PAM support and then create a slim module under /etc/pam.d. What I did was copy the /etc/pam.d/login module and rename it /etc/pam.d/slim for anyone who might need this info. Now on to the next problem.
I’m getting xruns every 2 or 3 minutes. Without any jack clients running (i.e. Ardour3 or guitarix) I’m still getting xruns. Setting are sample rate=48000, periods/buffers=2, frames/period=512, priority=85, and realtime is ticked.

Here are some helpful hints:

I’m on Fedora 17 with Planet CCRMA and didn’t have to do most of the “tricks” because they are already there. Some infos are also outdated. What I had to do which is described nowhere: I had to increase the priority of the USB-kernel-threads via rtirq because I own an USB-audio-interface.

Hi all. Not sure if this is the right place but I would like to know if Novation Impulse 49 MIDI controller can be used with Ardour and are there any problems in using it?

Ok I tried the suggested website and I saw it before but I’m still getting xruns. I feel progress has been made but I can’t use this system with xruns every 2-3 minutes.

Update: I have everything the same just chose frames/period=1024 and now no xruns. It sucks I can’t go lower.

At the risk of sounding like a broken record, AV Linux solved these problems for me and I can get absurdly low latencies without xruns. Ardour shows 5.3ms, and I think I can screw it down further but there’s no point.

But looking at your first post, are you sure your ordinary user is a member of a group that has real time privileges?
I can’t remember exactly how it’s done, but the link quoted says something about making yourself a member of the “audio” group, and then somehow the audio group has to be allowed real time scheduling.

Possibly this extract from the AV Linux 5.03 manual is relevant:

Many audio applications benefit from the user and 'audio' group permissions being set on the system Real Time Clock. This can be done easily using the 'Accessories' Root Terminal like this: → Create a blank text file called '40-rtc-permissions.rules' in the /lib/udev/rules.d directory with this command: gedit /lib/udev/rules.d/40-rtc-permissions.rules Now copy and paste this text into the blank text file you just created and click 'Save' in the gedit Text Editor: KERNEL=="rtc0", GROUP="audio" On the next boot the rtc will automatically belong to the audio group.

On some distros it’s the “jackuser” group.

Ok I tried adding the 40-rtc-permissions.rules file and rebooting it and I still get xruns at frames/period=512. I would have thought my laptop would be able to at least handle frames/period=512. It’s an AMD x64 x2 Athlon cpu with 3 GB of RAM running on a 32bit OS.

I’m on Fedora 17 with Planet CCRMA on a cheap Intel Core2 Duo laptop with 2gig RAM. Depending on plug-in usage I’m between 64 and 128 frames with 3 periods with very rare XRUNs.

Forgot to mention it is the 64-bit version and the processor is running at 1,8 GHz.

Wow now thats what I’m looking for. Unfortunately I erased my Beyond Linux From Scratch build and installed AVlinux-6.0 which is pretty decent. Everything seems to run pretty good.

I should mention that I currently don’t have “big” projects. If they grow larger I think I have to switch to 256 frames. What latencies do you achieve now with AVLinux?

Well with a Behringer FCA202 interface I can use 256 frames/period at 3 periods and 48000 rate. No xruns at all. Something is definetly configure right on this one.


I’m glad to hear that things are working better for you, Just a quick note to make you aware that AV Linux 6.0.1 is due to be released very soon (as soon as Mixbus 2.3 is released). 6.0.1 uses the same base libraries as 6.0 but will have many updated, new and improved packages including the latest Ardour, ArdourVST and Mixbus versions as well as pretty much every stable open-source and commercial (demo) LV2 and linuxVST Plugin and Instrument known to exist plus the most recent developments in other DAWs and popular Linux Audio apps.

There are of course upgrades available for users of AV 6.0 but if you haven’t gotten too comfortable yet I will really suggest installing the new version when it becomes available.

Im ready and waiting. The laptop will be used for live use mainly guitarix and a little live recording with Ardour3. When I’m not playing I’ll use it as an effects box for our soundboard which works really well. Thats why I decided to scrap the BLFS project and go with something more stable for now. Is there an estimated release date for 6.0.1?

One problem with promising a release date for 6.0.1 is that it’s dependent on Mixbus 2.3 as mentioned above - have Harrison promised a release date for that? I doubt it.

I have tweaked my 6.0 installation with newer kernels and a selection of extra packages, and Ardour 3.1 is running just fine on it. Oddly enough, a newer version of Scribus is the feature in 6.0.1 that I’m looking forward to most!

Ok guys been testing AVLinux-6.0 with my Behringer FCA202. I can’t go lower than 512 without getting xruns using Guitarix. I’ve turned off my network card closed all windows and I just can’t lower. There is slight delay with being set at 512 so that kind of puts a dent on things for live use. I guess the older AMD cpus really suck lol. Intel is in the near future if I can afford it.

Guitarix is known to be CPU hungry… Maybe you can check out other effect-plugins as well. The Calf-plugins are nice (except for the noisy EQ). Of course you need a host for plug-ins.

Calf Plugins are nice. Are there alternatives to Guitarix beside Rakarrak? Suggestions or recommondations welcomed.