Need a fix for my Cubase situation, so that i may switch to Linux and Ardour.

Hi everyone, I really want to make a transition from Windows and Cubase over to Linux and Ardour.

At the moment, i use a program called ‘Midi Mousekeyboard’ alongside Cubase using another utility linking the two together. The software allows me to play midi information directly into cubase using my PC keyboard. I then use a set of vst instruments such as synths and drums, controlled by the midi data, to create my desired sound.

Finally i bounce the output sound to a separate track using a vst plug-in called ‘tapeit’

I want to know if there is a work around that will allow me to continue using this in Linux.

I have been trying to work out a way, of maybe using wine, fst, rosegarden and ardour all together, to somehow to create a linked system. I’m just worried that all these programs will create a terrible slow down.

I would love to hear if anybody is using something similar. As i really want to switch to Linux, this is the only thing holding me back.



there is a virtual keyboard named vkeybd:
I don’t know it at all, just asked google to be honest.
you don’t need anything like “tapeit”, your favourite softsynths all support jack out of the box. You will need something like Rosegarden or muse or seq24 to do the midi stuff, but that syncs up with Ardour through jack.

All set to dump windows then!

Wine does work too, I don’t know how good it is for “close to the metal” hacks like Midi Mousekeyboard though. Better if you can do without. You will need wine if you rely on VST, some of which seems to work.

Hey Seb;

Thanks for the advice, i had already come accross that utility today after my post, as well as another one (can’t remember the name)

I think what i shall do is use Jacks to route from vkybd (virtual keyboard) into a vst software such as pro-53, then the audio from that into a stereo track in Ardour.

For my drums i think i will route from vkybd, through pluggo 74, then into something like Rosegarden to record the midi, while at the same time routing and recording into Ardour as an actively monitored channel…maybe somehow:/

Question; Is it possible to record in both Ardour and Rosegarden at the same time? Will one or the other continue to run in the background, completly in sync?
Finding work around’s and fixes are the norm for me, as i usually like to route and fly between apps. I’m just hoping that these extra programs with Wine wont be a major slow down.

One of the primary factors for me wanting to switch, is my impression that Linux is less of a system hog. Windows is driving me crazy, i adore the community approach to linux, and the choice of software.

Which brings me to a couple of questions, I am having a little difficulty deciding upon a suitable distro, and a desktop model. At first i thought maybe fedora 5 with KDE, then maybe Ubuntu with Gnome or even maybe Kubunu. It’s all quite confusing though, it’s hard to settle just on one.

My laptop is Intel Centrino 4 1.6 with 512mb of RAM. I’ve heard that the latest versions of KDE and GNOME are quite bulky, which made me look at xfce. The information out there about Linux is great, but there is really a little too much! It’s hard to make a clear decision with so much choice.

For now, I’m going to give Musix .99 live CD a try, so that i can get a feel for Ardour and Linux in general.

I did install mandrake many years ago, on an old 286 and then 386, but didn’t really use it a whole lot.

Is there a release that is slimmed down for laptop use, that would allow me to run mainly sound editing software, but also a word processing and cd burning application.
I would appreciate any thoughts you, or anyone else may have to offer.



You do not need a slimmed down distro for laptop use. Linux doesn’t work that way. Musix is a reasonable start, and has the benefit that it should work “out of the box”, but for a more full-fledged Linux experience, I would still recommend using Fedora plus Planet CCRMA as an “overlay”, or the shortly-to-be-released Ubuntu Studio. You might find that you need to disable a few system services, but in most cases, this is not necessary. As a single data point, I can play back a 22 track session in Ardour while (a) doing a dual-processor compile of Ardour itself (b) visiting websites in firefox © fetching email in evolution (d) doing live IRC chat with xchat (e) listening to internet radio in rhythmbox via JACK … all running at the same time, with absolutely no dropouts/clicks despite the 100% pegged CPU usage. This is with about 5msec latency on a specially built RT kernel, on a dual opteron system.

Yes, you can have any number of JACK clients recording at the same time, but you will be creating extra pressure on your disk subsystem because there is now duplicate data being written to disk. If you’re using RG to record MIDI and Ardour to record audio, this is not a problem.

Thanks Paul; I think I’m getting there;

I’m on Ubunutu 7.04; it took me a couple of days to set-up my wireless card; but now mi ready to move on. I have installed Ardour2, jack and the quick jack gui. But every time i start ardour from the terminal i get this msg;

jackstart: md5 checksum for /usr/bin/jackd does not match
ardour: [ERROR]: Unable to connect to JACK server
ardour: [ERROR]: Could not connect to JACK server as “ardour”

-A box then pops up stating that Ardour could not connect to jack;

There are several possible reasons:

  1. JACK is not running.
  2. JACK is running as another user, perhaps root.
  3. There is already another client called “ardour”.

If i try to load the Jack Audio Connection Kit, i get this error;

Could not connect to JACK server as client; please check the messages window for more info.

I would really appreciate the help, as the closer i get, the further end up bieng. It is so difficult for a new user to get to grips with linux.



for me it looks like you are trying to start jackd with realtime, but the user is not having the needed privileges to run jackd with realtime.

try starting qjackctl after unchecking ‘realtime’ option in the (qjackctl’s) settings dialog.


You were right nowhiskey; how can i get it to run in real time? With the frames/period set to 64;sample rate 48k; periods buffer 10. I’m getting xruns though, my latency is, some xruns are over 30ms. My ardour is running at 100%dsp when recording, surely this is not normal?

I have a p4 2.4ghz, 1gb ram and an external UA-25 USB audio interface. Cubase would run fine on this setup, is linux really that power hungry???

not at all power hungry, i am able to record 16 tracks simultaneously at about 15-20% of cpu!
i don’t know what is the problem in your set-up, but most probably you are not running an rt-kernel.
type ‘uname -a’ in a terminal it will show you which kernel is running there.
here it looks like:

nowhiskey@murija2:~$ uname -a
Linux murija2 #1 PREEMPT Thu Mar 15 16:17:48 CET 2007 i686 GNU/Linux

getting rt-privilegies is given by using rt-patched pam modules.
i am here on debian, but for longer now i am using pam modules from ubuntu:


have a look into /etc/security/limits.conf, there you should have a part like:
@audio - rtprio 99
@audio - memlock 500000
@audio - nice -10

or similar.

also i think that frames/period set to 64 is too low, try increasing it to 512 and setting the buffer than to 3 or 2, perhaps you get better results with it.


Linux home-desktop 2.6.20-12-generic #2 SMP Wed Mar 21 20:55:46 UTC 2007 i686 GNU/Linux

That is my kernal; you were right…again! Now before I go google hopping into how i install a real time Kernel. Is there a specific version i should target? What would give me the best latency for audio apps??

Thank you again nowhiskey!

don’t know the current status of ubuntu-studio which will have a rt kernel, but on the LAC someone told me that the kernel from the 64studio repository is fully compatible with debian, so it should be the same in ubuntu.
64studio is packaging for 64bit architecture, but they also have an 32 bit repository.
i think that it is worth of having a look there!



it appears to me that you have installed two versions of JACK. this is not OK. you could debug your setup much more rapidly if you joined us on IRC. start up xchat and connect to, then /join #ardour

in addition, you should not use the “jackstart” command to start ardour (qjackctl needs to remove this option). that is for 2.4 kernels only, and should not be used with 2.6-based systems.