nanoKONTROL2 in Ubuntu Studio 16.04

I’m a bit desperate after hours trying to configure my nanoKONTROL2 in Ubuntu Studio 16.04. I’ve selected my device under generic MIDI settings but it makes no effect and nothing works (when it should do it automatically, as I understand) so I attached some images with my current settings. I can assign some controls manually like volume, R, M, S and the main playback controls, but it doesn’t let me use the knobs to manage the stereo sound balance (they work, according to the MIDI tracker, but when I try to manually assign them, they don’t seem to respond). I also don’t know how to assign the marker buttons (set, forward and rewind). Can anyone help me?

About my setup, I don’t know if it makes much sense to link my nanoKONTROL2 to Midi Through Port under ALSA settings (and viceversa). The thing is, if I link them, the light on the buttons lits when I press them, but it doesn’t stay lit. If I unlink them, S, M and R stay lit when I press them, but the rest of the buttons don’t lit up at all.

Isn’t there already a midi-map for the nanokontrol? Instead of using Jack, go to the preferences menu and somewhere there’ll be a tab for control surfaces. I am pretty pretty sure there has been a map for the nanokontrol since Ardour 4.

Thanks, I’ve already done that, as you can see in the screen capture I’ve selected nanoKONTROL2 in control surfaces. I don’t know what you mean by not using jack.

Hi, I remember using a NanoKontrol2 with Ardour a few years back.

I had to add “usr/bin/a2jmidid &” in qjackctl in the scripts to run at start (when using Jack, of course…), then I reconfigured the NanoKontrol.

I’m sorry I cannot remember which works the best, but the NK2 can be set in different DAW modes by plugging it with some keys pressed.

  • SET MARKER and REW buttons to be in Cubase mode,
  • SET MARKER and FF buttons to be in Digital Performer mode,
  • SET MARKER and STOP buttons to be in GarageBand mode,
  • SET MARKER and REC buttons to be in Sonar mode,
  • SET MARKER and PLAY buttons to be in ProTools mode,
  • SET MARKER and CYCLE buttons to be in “other DAW” mode.

Try the combinations above, and see which one works the best for you.


1 Like

Thanks a lot, that what really helpful!