Mystery noise/feedback, inhibiting work

I have a recurring problem with ardour (on Ubuntu Edgy’s repos)

As soon as I add a track (which connects Ardour to ALSA thru JACK as you know), I have a consistent level of ANNOYING/INHIBITING noise or feedback.

All the JACK connections are correct, my microphone is not to blame, but when I disable the 20dB boost, the noise cuts back to about half level, but its still abnormal.

I had a less severe problem with this before, and it affects new recordings, they pick up the annoying noise.

When I play old tracks, the noise disappears when the track is playing, but when it stops, the noise is there.

I think something is wrong with ALSA, but I can only create this result in Ardour. No other JACK applications suffer from this, and I can’t reproduce this in any other audio applications.
I don’t think it is user-settings, because both my regular user and studio user suffer the same problem, so all I can picture is a hardware or ALSA problem. Searching has turned up no similar problems from other users.

Can anyone throw me a bone here? Any idea you may have is appreciated, my workflow has ground to a halt because of this nonsense. I need my beloved Ardour!

Cheers, and thank you kindly for any advice! If you need any more info, like my JACK settings, screenshots, recordings, anything, please ask and I will produce. Thanks again

When I play old tracks, the noise disappears when the track is playing, but when it stops, the noise is there.

This suggests that the noise is comming from your capture device. By default, Ardour automatically connects new tracks to the capture device. When not playing, the sound from the device plays through, but is turned off during play back.

The capture device may be generating noise / feedback for any number of reasons.

I would make sure that all your tracks inputs are disconnected from the capture device(s) and then try to find why it is making that noise.

Thanks for the advice Reuben

Considering the effect the 20dB boost has, and what you described above, I’m thinking more and more along the lines of hardware problems, maybe static or something like that.

Whatever it is I’m going to get to the bottom of it. I’ll be back with info and results, for anyone with more ideas for me, and for reference for others who encounter this in the future.

Do you see the noise you are talking about in any of ardours’ meters?


Yesterday I installed Ardour2 from an Ubuntu “edgy” package, and since then I have the exact same problem. The noise also shows on the level meters of Ardour. When I remove Ardour2 and go back to 0.9 (default Ubuntu package) the noise isn’t there anymore. It’s a very weird problem.

Did you tried to disable monitoring (hardware and/or software) in Ardour’s options?

Yes, in the mixer the noise is very visible. Funny thing today I’ve noticed, even when my speakers are turned off, if I turn my master volume above about 95%, there is an intense loop feedback which goes to full level in the meter. @ 94% it sits at the normal weird level. Bizarre.

TomB, I’m using 0.9, I wonder, did you fiddle with monitoring in Ardour2 like hsyl20 suggested?

hsyl20, disabling hardware monitoring seems to have no effect, disabling software monitoring turns off the mic input completely… Does this suggest anything?

Thanks greatly for your input everyone, its a frustrating problem. I’m going to try opening up the tower, I don’t have my CDROM grounded to the tower, its not likely but maybe its causing some kind of static. I’m going to blow out a bunch of dust around the sound card aswell.

From Reuben:
“The capture device may be generating noise / feedback for any number of reasons.”

Anyone able to suggest any other reasons for feedback from the capture device?

A couple quirky notes:

In my master mixer (currently gnome, but same in KDE), adjusting the mic volume, or muting has no effect anymore. However, changing the 20dB switch still works. It seems like my mic has been hijacked somehow.

THIS specific feedback problem started after I manually forced Ardour to interface with JAMin. I can’t recall how I arranged the connections, but I was frustrated with JAMin not getting the feed, so I MADE it connect to Ardour. Of course the jack connections returned to default afterwards, but I feel it may have some bearing. It not be related though, trying to recreate the same setup didn’t change anything.

Will post update :smiley:

Yeah, no dice with grounding CDROM or compressed air dusting.

I’m officially stumped. :frowning:

I’m getting a little more feedback in R than L now though ::rollseyes::

What if you mute all the tracks in ardour? Does that eliminate the noise? If yes, then start unmuting track by track to find the noise source.

It’s very possible you have noisy sound card, and you have software monitoring and auto input engaged. With this configuration, all tracks pass their input to their outputs when the transport is stopped. If there are multiple tracks, the noise will build up and eventually be audible.

Thanks for trying to help me sampo :slight_smile:

Muting tracks does eliminate the noise, but each individual track carries the noise, I can’t find any single source for the noise from a track.

I think you must be right about having a noisy sound card, but its baffling how it goes from being normal to unusable so suddenly.

I should point out that for my soundcard I have inputs at the back of the tower and at the front. I just cleaned out the front and back thoroughly, and while I still get the noise, it’s now a rapid reverberation of noise, so I think I can safely say that Ardour has nothing to do with my problem.

I’m going to unplug the front inputs and see if they are to blame for the noise.

Thanks again everyone for your input, its helpful when others are around to offer ideas! Cheers!


Not the solution I was hoping for, BUT I dug an old card out of a terribly old PC, slammed it into a spare PCI slot, and now I finally have a peaceful silence.

Thanks everyone for bearing with me and my vague notions and ideas, I’m glad I finally figured it out.

Now I can get back to work. :smiley:

Back with more noise problems. In the time the second card was working I was able to record enough to keep me busy working for a while, but now the noise has spread like a cancer to that card, and both cards are now affected.

Browsing M-Audio’s website, I came across this FAQ section about Ground Loop noise transferring to the sound card:

Has anyone heard of this before? I hadn’t, and it seems to be exactly what I’m experiencing. I’m having trouble tracking down what other hardware is off the ground loop, but I also don’t know too much about the subject.

Anyone know anything about Ground Loop Noise?

If certain noise has spread like a cancer to that card, and both cards are now affected. Any way i like such stuff bur right now engaged in my microsoft tests that is why i am busy right now. Any how just keep it up!