my midi's being stupid again halp


(Garrenwee13) #1

It’s a video I made about the problem that I experienced. (The growl’s super loud I’m sorry)

The main issue is that Ardour is choosing not to play some notes depending on where I place the playhead. I know it’s super impromptu, but hopefully you guys can see where I’m coming from more clearly.

Specs:
Windows 10
Ardour 5.12
8.00 GB RAM
256 GB SSD

The error I’m facing’s horribly systematic. So I’m left wondering, is there a setting somewhere that I left open by accident? Or has the program decided to go rogue and betray me? xD


(Garrenwee13) #2

Dove further into this: https://youtu.be/mIvA4Xubcuw
Think i found the reason for the bug.
Voice still sounds like I’m eating 12 marshmallows at once.


(Paul Davis) #3

This is alsmost certainly caused by known bugs with MIDI timing. There’s been a lot of work going on (see https://community.ardour.org/node/15693) to get this fixed. There’s no simple fix that can go into a release based on 5.x. Sorry about this.


(Garrenwee13) #4

Hey Paul, thanks for your reply. No problem, I have faith in you guys that you’ll get it fixed sooner or later :wink:

Just one more question: is the bug in the first video related to the bug in the next? I’m just wondering if the automation bug in the second video has anything to do with the midi bug you’re talking about now. Maybe that will help you guys a bit also.


(Paul Davis) #5

Yes, it’s almost certainly the same bug.


(Robin Gareus) #6

You can mitigate the issue by decreasing the readahed-time in Preferences > MIDI to the minimum. That way you only need to rewind to 100ms in front of upcoming midi-events…


(Jayedmondseay) #7

I had a similar issue with the playback. when you want to play a region there is an option to “play from start”. so if you loop a new segment or move a midi file from its original location … sometimes it wont read correctly even if every other setting is correct. I have to disengage the loop button, click on the segment and choose to play from start, stop and then loop region and it usually fixes the missed notes. (Especially playing back short parts.)