mute not working

I have 2 PC (stationary and netbook) both with ubuntu 9.10
And the mute doesn’t work on all the channels of ardour on both of them. (solo is okay)

Same thing on my Opensuse 11.2 with the ardour 2.8.6
(built from revision 6555)

Edit /home/YOURUSERNAME/.ardour2/ardour.rc like this:

Option name="mute-affects-pre-fader" value="1"/>
Option name="mute-affects-post-fader" value="1"/>
Option name="mute-affects-control-outs" value="1"/>
Option name="mute-affects-main-outs" value="1"/>

That should fix it.

Also right-click on the mute buttons and make sure the applicable boxes are enabled.

I think flying penguin’s suggestion will fix the problem for you in the future.

But does anyone know how/why these get disabled?

@Ben and others

The corresponding bug report has some more infos on this:

It seems the settings from /etc/ardour2/ardour_system.rc are not interpreted correctly and so ~/.ardour2/ardour.rc gets created with the wrong values.

thanks very much

Got the same problem, but “flying penguins” suggestion didn’t do it for me. Weird. It just suddenly happened… it used to work. Even reinstalled Ardour and downgraded to a previous version without solving it.