Mute does not work on 2.8.6

Hi - problems again!

It seems that in certain of my sessions, mute does not work. The mute light comes on, but the channel continues playing. Even with all channels (including master) muted, all channels are still producing sound.

However, solo works.


I have monitoring set to ‘ardour does the monitoring’, and have checked that there are no channels bypassing ardour in jack.

A wrong setting maybe?

It’s an Ubuntu bug, if you build ardour from source you’re not affected. Anyway, the solution is to edit the file


found in the .ardour2 directory in your home. In that file, you find the lines:

Option name=“mute-affects-pre-fader” value=“0”/>
Option name=“mute-affects-post-fader” value=“0”/>
Option name=“mute-affects-control-outs” value=“0”/>
Option name=“mute-affects-main-outs” value=“0”/>

you have to change all the “0” with “1”, like this:

Option name=“mute-affects-pre-fader” value=“1”/>
Option name=“mute-affects-post-fader” value=“1”/>
Option name=“mute-affects-control-outs” value=“1”/>
Option name=“mute-affects-main-outs” value=“1”/>

Now in all your new projects mute will work again. For existing projects, right click on the mute button and check everything.

Or you can download one of my debs, either ardour or ardourvst, both at version 2.8.7 for lucid, from my repository. To add my repo to your sources, just install this file:

Once you've installed this file, you can add dream-ardour or dream-ardourvst from within synaptic, or with apt-get install at the command line.

@vervelover: thanks :slight_smile: No idea why this option is turned off by default in Ubuntu Studio – seems pretty dof to me.

@macinnisrr: Thanks. will install the latest version from your repository.

Problem solved.

@macinnisrr: something wrong with the repository?

Failed to fetch Unable to find expected entry main/binary-amd64/Packages in Meta-index file (malformed Release file?)
Some index files failed to download, they have been ignored, or old ones used instead.

Hmmm. Maybe you are running vanilla i386 distro? I’m running am64. Pity.

sorry, no amd64 support in my repo. I use an rt-pae kernel with i386 (which supports up to 64GB RAM and works on amd64 systems). My packages work with stock ubuntu i386, but they are meant to be used with my own Dream distribution (based on ubuntu i386 with the above kernel). Until we get to a stage where systems with >64GB RAM become the norm, I will only be maintaining one version of these packages. It’s much easier for me to maintain a distribution with 1 version of all packages (and two kernels, as some cpus don’t support PAE, though not many nowadays).