Multiple mics on Ubuntu

Hi guys

my windows 10 PC just died and I am back on a somewhat older Linux box. On Windows I could happily use 3 identical mics with Asio. Under Ubuntu I am not having a prayer.

Alsa only allows me to use one device and appears to be seeing 2 of the mics. The default session that should pic up the inputs doesn’t under pulseaudio nor ALSA.

The startup dialog of Ardour offers a button for device configuration similarly to Ardour with Asio on Win10do, but when I click it, nothing happens and Google is silent on the subject.

The system sees all three USB mics no problem:

cat /proc/asound/cards
0 [SB ]: HDA-Intel - HDA ATI SB
HDA ATI SB at 0xfdff4000 irq 16
1 [NVidia ]: HDA-Intel - HDA NVidia
HDA NVidia at 0xfcffc000 irq 19
2 [Audio ]: USB-Audio - Bravo-X USB Audio
SAVITECH Bravo-X USB Audio at usb-0000:02:00.0-1, full speed
3 [Device ]: USB-Audio - USB PnP Audio Device
USB PnP Audio Device at usb-0000:00:13.2-5.4.2, full speed
4 [Device_1 ]: USB-Audio - USB PnP Audio Device
USB PnP Audio Device at usb-0000:00:13.2-, full speed
5 [Device_2 ]: USB-Audio - USB PnP Audio Device
USB PnP Audio Device at usb-0000:00:13.2-, full speed


Thanks in advance!

There currently is no easy way to use multiple devices.

The least painless way is likely to use JACK:

The explanation given on that page is also why Ardour itself does not support it: To be able to use multiple soundcards, the signal has to be resampled to keep them in sync, degrading quality.

There is however experimental support for this in Ardour 6. You can try to start ardour in a terminal window like this:

ARDOUR_ALSA_EXT="hw:3;hw:4;hw:5" Ardour6

and in the Audio/MIDI Setup dialog select Ardour/ALSA with “USB-Audio - Bravo-X USB Audio” (hw:2) as main device for I/O (which provides the sample-clock). The three “USB PnP Audio Device” (cards 3-5) are added in addition.

That’s normal.

On Linux most devices or drivers do not come with a config tool. When using Ardour/ALSA the button should also be insensitive (grayed out). Only some RME devices and some firewire devices have a dedicated “Device Control Panel”

First of all: Thanks a lot!

did you mean to say “least painless”? ;o) cos so far this is not intuitive :wink:

Hmm, alsa_in seems not to be an option:

1st window:
$ alsa_in Device
selected sample format: 32bit
delay = 3421
delay = 1023

2nd Window:
$ alsa_in Device_1
Capture open error: Device or resource busy

so, next option, the experimental option

Hmm, that no workee either. The Audio/Midi setup dialogue is bypassed and I don’t see the mics. See attached screenshot.


alsa_in -d hw:3
alsa_in -d hw:4
alsa_in -d hw:5

or perhaps also specify a sample-rate for each device

alsa_in -d hw:3 -r 48000

Use Menu > Window >Audio/MIDI Setup, perhaps you had “autostart” enabled, or JACK was running and Ardour automatically connected to it?

1 Like

so we’re having fun. This works and lets me configure the three mics in Ardour. But: They get some weird weird signal that is definitely not audio. These are wireless mics and 2 of the transceivers do no even have batteries in.

As for the Alsa experimental feature, it doesn’t let me configure it:

Edit - this is the same USB device you suggested. It changed name …

Using the ARDOUR_ALSA_EXT “experimental feature” overrides any configurability. It is meant to be used when you know which device(s) to use and the GUI would not be powerful enough to specify it.

And in that screen shot, left side terminal window, it appears that JACK is running, which won’t work.

Well …

I just tried this again.

  1. use qjackctl to make sure that Jack doesn’t run
  2. ARDOUR_ALSA_EXT="hw:3;hw:4;hw:5" Ardour6
  3. audio/midi dialogue starts with Jack suggested and the output as per below screenshot. It look as if this option starts Jack

detailed output of the terminal

bernhard@Bob:~$ ARDOUR_ALSA_EXT=“hw:3;hw:4;hw:5” Ardour6
Ardour6.5.0 (built using 6.5 and GCC version 6.3.0 20170516)
Ardour: [INFO]: Your system is configured to limit Ardour to 1048576 open files
Ardour: [INFO]: Loading system configuration file /opt/Ardour-6.5.0/etc/system_config
Ardour: [INFO]: Loading user configuration file /home/bernhard/.config/ardour6/config
Ardour: [INFO]: CPU vendor: AuthenticAMD
Ardour: [INFO]: AVX-capable processor
Ardour: [INFO]: CPU brand: AMD FX™-8320 Eight-Core Processor
Ardour: [INFO]: Using AVX optimized routines
Ardour: [INFO]: Loading plugin meta data file /opt/Ardour-6.5.0/share/plugin_metadata/plugin_tags
Cannot xinstall SIGPIPE error handler
Ardour: [INFO]: Loading default ui configuration file /opt/Ardour-6.5.0/etc/default_ui_config
Ardour: [INFO]: Loading user ui configuration file /home/bernhard/.config/ardour6/ui_config
Ardour: [INFO]: Loading 449 MIDI patches from /opt/Ardour-6.5.0/share/patchfiles
Ardour: [INFO]: Loading color file /opt/Ardour-6.5.0/share/themes/dark-ardour.colors
Ardour: [INFO]: Loading ui configuration file /opt/Ardour-6.5.0/etc/clearlooks.rc
Ardour: [INFO]: Loading bindings from /opt/Ardour-6.5.0/etc/ardour.keys
Loading ui configuration file /opt/Ardour-6.5.0/etc/clearlooks.rc
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock

also, I do not understand this statement:

" Using the ARDOUR_ALSA_EXT “experimental feature” overrides any configurability. It is meant to be used when you know which device(s) to use and the GUI would not be powerful enough to specify it."

what would you like me to do instead? The command leads to the audio/midi config dialogue.

Sorry, my mistake. I was thinking of a different ARDOUR_ALSA_* hack. Disregard my comment about it.

Yes that configuration will start JACK, which you do not want. You want the ALSA backend, not JACK.

It seems likely that PulseAudio on your system is making your life difficult. Maybe someone will guide you through dealing with that.

I disabled the 3 mics in Pulseaudio. How do I avoid Jack being started as soon as I call Ardour that way?

Oh and thanks!

So you have gotten great advice so far, but let me just reitterate a couple of things before jumping into something else:

  1. This is not easy, and really not supported. What you are doing is trying to use three different sound cards, each with their own clock, and from the sounds of it no way of syncing their clocks, and get them to work with Ardour which likes to use a single clock for everything. The suggestions so far are not really fully tested and are still being developed.
  2. This is made even worse with the use of wireless mics. The noise you heard might actually be the mics working as expected, as even if the transmitter is not on, the receivers might pick up background noise which can sound like a variety of things but really loud static/white noise is very common for this (Even low level background RF noise can cause very loud sounds, if you were old enough to remember analog TV, think of how loud the static would get on stations that weren’t there). Many wireless mics use a squelch setting to adjust how sensitive they are to background noise, but this may be software controlled, and if that is the case even though you can use the device as class compliant audio on Linux, you may not be able to set/control other settings about it. What wireless mics are these? Was there any software specific to them that you ran in Windows?

Not saying don’t keep going, just know what you are dealing with.


First of all, thank you!.

I am having a feeling that the noise maybe my 3rd party DAC that I am using as a soundcard. About to test this. The mics use generic drivers and simply get recognised. In Windows I solve the whole thing via ASIO which works beautifully. The thought that something works better in Windows on a system level than in Linux rankles a bit :wink: I’ll be back with my test results in a bit

Yup, disconnecting the little DAC solved this. Now works with JACK. Thanks all!

I can only recommend them

Heh for the record, wireless you get what you pay for, I would never recommend these for live usage certainly, but for some uses I suppose they could work. I would be very wary utilizing multiple of these for instance with no external antenna management etc. It is hard to get useful info on this particular setup, for instance latency or whether there is even a squelch circuit, but it seems geared primarily towards the videoconference crowd where audio quality and latency are not nearly as large issues as might be needed live or in a studio.

As I said for some people they may work, and if they are working for you then great!


we’re using them for youtubing and I am quite happy with them. used them for videoconferencing too without issue

edit: and they seem to have squelch, since there is no noise when the transceiver is switched off (which presumably counts as having lost connection?)