multiface 1


Sorry to be a bit off topic, but as the Ardour site recommend hdsp multiface as a good soundcard under linux, I might find some help here…

I got an old multiface 1, running A1 with the pci card on UbuntuStudio. The thing is I can’t get it to work on my laptop with the cardbus, same system.

Installed :

alsa-firmware 1.0.14
alsa-firmware-loader 1.0.14

sm@sm-laptop:~$ lspci | grep CardBus; lspci | grep RME
02:00.0 CardBus bridge: Texas Instruments PCI1510 PC card Cardbus Controller
03:00.0 Multimedia audio controller: Xilinx Corporation RME Hammerfall DSP (rev 0b)

sm@sm-laptop:~$ uname -a
Linux sm-laptop 2.6.20-16-lowlatency #2 SMP PREEMPT Thu Jun 7 20:23:03 UTC 2007 i686 GNU/Linux
sm@sm-laptop:~$ cat /proc/asound/cards
0 [I82801DBICH4 ]: ICH4 - Intel 82801DB-ICH4
Intel 82801DB-ICH4 with AD1981B at 0xd0000c00, irq 11
1 [DSP ]: H-DSP - Hammerfall DSP
RME Hammerfall DSP at 0xd4000000, irq 11

Trying to load the firmware with hdsploader :

Looking for HDSP + Multiface or Digiface cards :
Card 0 : Intel 82801DB-ICH4 with AD1981B at 0xd0000c00, irq 11
Card 1 : RME Hammerfall DSP at 0xd4000000, irq 11
Upload firmware for card hw:1
Hwdep ioctl error on card hw:1 : Input/output error

I’ve been looking all day on google without any luck. Don’t know where to look next.

Any help would be greatly appreciated,


lol… anyway I meant recompiling alsa-firmware! :wink: Welcome to Ardour :wink:


Recompiling the whole Alsa thing was very… instructive! :slight_smile:

Aie !

I’m happy, I solved my problem… by changing the ac adaptor !!! The card is supposed to work with power from 6 to 40 V, I switched from 12 to 18 and bingo, I could load the firmware… I never imagine that could be the problem… I switched back to a 12v ac adaptor and I wasn’t able to load the firmware again.

Thanx a lot anyway for helping !

When I have these kind of problems, everything goes right if I recompile form source ALSA. Try this, it should fix your situation.

While this may not be the source nor the end solution to your problem, it looks like your on-board audio is sharing an IRQ with your multiface which may be causing conflicts. Don’t know if it’s possible with your laptop, but my recommendation would be changing the IRQ of your multiface, or better yet turning off the on-board audio off entirely in from your BIOS settings. (As a side note, my intel on-board audio had recently been causing me grief). Other than that, maybe double checking if you have cardbus support enabled in your kernel (believe ubuntu does, but not sure). Does HDSP show up at all in lsmod?

Thanx for you reply,

Yeah I’ve seen the thing with the IRQ…

Yes I have cardbus support (yenta compatible in my case) as a module in the kernel.

Everything is there in lsmod…

lsmod | grep hdsp
snd_hdsp 51588 0
snd_hwdep 10500 1 snd_hdsp
snd_pcm 80260 4 snd_hdsp,snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_rawmidi 25856 2 snd_hdsp,snd_seq_midi
snd 54788 14 snd_hdsp,snd_hwdep,snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
snd_page_alloc 10888 3 snd_hdsp,snd_intel8x0,snd_pcm

I’ll check for IRQ but it’s working fine with the same IRQ on the pci bridge.

I keep searching…

Thanx again,

cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.14.
Compiled on Jun 21 2007 for kernel

Did compile the alsa drivers and libs from source, same old… same old…

hdsploader - firmware loader for RME Hammerfall DSP cards
Looking for HDSP + Multiface or Digiface cards :
Card 0 : RME Hammerfall DSP at 0xd4000000, irq 11
Upload firmware for card hw:0
Hwdep ioctl error on card hw:0 : Input/output error

It has to be something with the cardbus. I’ve seen a message from Paul Davis saying to downgrade the firmware of the cardbus (need windows) but the problem was not the same, the soundcard was loaded but wasn’t sounding good.

Keep searching…

Thanx a lot for helping,

I now have kindo of exactly the same problem…
tried to use my multiface II, which i usually run on a tower, on my laptop via pcmcia, and it doesnt work, telling me device is busy… and i also have the same irq 11 on both soundcards, the onboard and the interface:

cat /proc/asound/cards
0 [I82801DBICH4 ]: ICH4 - Intel 82801DB-ICH4
Intel 82801DB-ICH4 with AD1981B at irq 11
1 [DSP ]: H-DSP - Hammerfall DSP
RME Hammerfall DSP + Multiface at 0xc4000000, irq 11

my try would be schanging the irq s BUT I DONT KNOW HOW… can anyone help me???

Have you tried disabling the intel card in BIOS or unload the driver prior to connecting the RME?

thx peder, yes, finally it works, but it was more my stupidity… ;(
the new ubuntu jaunty doesnt need that you start hdsploader at the beginning, the soundcard works out of the box (at least in my case now) , and i had to disable the onboard soundcarsd by an entry in the blacklist… but now its ok… of course it crashes always when i tried to run hdsploader…