multi-channel monitoring and export

I’ve just installed Ardour on OSX hoping it’ll let me mix 30-channel soundfiles. Started a basic test with a 12-channel file but dont seem to find any way to bypass the routing of 12 channels to stereo. Nor can I export anything other than a stereo file.

Have I completely missed something?



do you mean routing from a 12-port track to the master bus ?

By “12-port track” I guess you mean a track configured with 12 channels. So, I add a new 12-channel track, stick a 12-channel soundfile on it, route it to a 12-channel master. Result is choas…

check in the routing window that the port (channel) connection is right (one-to-one mapping I supppose).

Which kind of monitoring system do you use for such a soundfile ?

Yep, thats all correct, one-to-one.

Also I see that although I have 12 meters within the 12-channel track, their levels do not correspond with the actual contents of the soundfile. It appears as if the 12 channels are being panned incrementally left-right (as shown by the orange dots which indicate panning on simpler track formats.)

Also the export file, region and session options are only stereo.

Surely there is some preferences option I’ve missed?

if your routing is correct and have a level problems, it could well be bug. A dev would be needed (bug tracker).

Have you tried to experiment a little like splitting the material into 12 mono regions and work with 12 individual mono tracks ?

OK. tried splitting into monos and setting up 12 mono tracks routed to the 12-channel master bus. Still same problem - levels in master do no tally with the levels being sent.

But still, maybe I havent set up the session correctly: there is the issue of only getting a stereo output when I try to export. Any clues there?

no clue, I never worked with more than stereo channel tracks … hope a dev can enlighten you.


  1. ardour 2.X does not do multichannel export. ardour 3 (unreleased) does/will.
  2. the 2d panner is basically useless
  3. given (2), if you want to get something close to what you appear to expect, you need to bypass the 2d panner entirely (right click on it for the context menu)
  4. ardour will allow you to mix stuff with any number of channels. you might want to consider bypassing the master bus entirely - its not clear if that would appropriate from your description.
  5. for a much better way of handling the panning for multichannel audio: Using Ambisonics with Ardour

Thanks! Bypassing the panner is what I missed (using a Mac with single mouse button…) Now I get direct routing and can record the multi-channel mixdown back into a multi-channel track to get round the multi-channel export issue.

But there is one more thing that appears obvious: the volume ‘rubber bands’ visually vanish after the soundfile has been moved, even though the volume automation is still working (the break points themselves remain). All is fine on mono and stereo files - problem only occurs on multi-channel files. Maybe there is another menu item I’ve missed?

Nope, that sounds like a bug, report that one in Mantis please?