Moving back to 7.4

Due to some problems with 7.5 (ambiguous latency coming from midi busses) I would like to revert to 7.4. Where could I download it? TX for answering.

Sorry, but we do not make older versions of Ardour available via our download system.

There is no change from 7.4 → 7.5 which can explain this. So going back to 7.4 will make no difference. More likely is that something in the session changed.

Assuming you are using JACK, more likely it is an a2j issue. There was a recent report on IRC about a similar problem. – Could you post the output of jack_lsp -cl ? That may shed some light.

1 Like

It is solved now. I think it was related to jack and a2j, as x42 said yesterday. It was affecting all sessions that I would open, new session (from template) included. Here is the last jack_lsp -cl I made yesterday : ardour:physical_audio_input_monitor_enable port playback latency = [ 0 0 ] f -



sorry : ardour:physical_audio_input_monitor_enable port playback latency = [ 0 0 ] f -

Actually I got the same latency problem, back from other activities, I open Ardour and find all midi tracks are a little delayed compared to audio and metronome (I use audio files on mine).
I am on pipewire and and not using any midi device (I have even removed the midi input in case it changes anything). It does on all my sessions.
I changed the metronome to use default sounds and I get the same, a bit forward the 2 midi tracks (drums with drumgizmo and bass on sfizz soundfont player).

I didn’t see pipewire update in the meanwhile. I am on ArtixLinux (derived from ArchLinux) with a standard kernel, RT priviledges on, sample rate is at 48k with 512 samples ~ 10ms latency)

Edit: I have just downgraded Ardour to 7.4 and problem is solved, so it seems there is something going on on 7.5.

So one question would be, does it still do this utilizing strictly ALSA, not pipewire?


Actually yes. I wont test again now as I stick with 7.4 for now to be able to use Ardour correctly, but I have effectively tried to switch to Alsa and the problem was the same.

Edit: if I get hints on what to check/look for, I can restore Ardour 7.5 to find out the problem

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.