Moved Projects

Dear All

I’m on OsX and i’ve moved some of my Ardour’s projects to my external HD.
Now if i try to open a project from the USB external drive i can’t ear any sound.
I’ve tried to move back to the original path, and i can ear the audio just with audition option, but if i play Ardour i can’t ear no sound.
Maybe i’ve forget something basic?

thank you very much for your work


i’ve also another issue about this problem:

The project all losts the indication about panning and dB after moved to the external drive, and moved back to the hard disk.
It seems like te tracks are on the timeline (i can listen to the audio files through the audition option)
but all the tracks have lost their propertis such as “stereo-track” or “bus”.

Do you all guys knows any solution for my problem?

thank you very much for attention


could someone please give me some help?
I can’t understand if it’s a bug or i’ve missed something reading the manual.

thank you so much

I’m not sure if I can help or not, but I’m willing to try. When you say you moved your projects to an external hard drive, do you mean you just copied and pasted all the files from the project folder? Or did you export the tracks to .wav files? Maybe if you could provide even more details, I (or someone else) might be able to point you in the right direction. I will try to recreate the scenario you’re experiencing as well, so maybe I can better understand what you are saying.

I mean Projects as the Ardour Session referred to a song so: the folder containing all the audiofiles, automations, dead sounds, peeks, etc…

If i move that folder, to another path or an external drive, when i try to re-open from ardour
i can see all the automation in the arrange window, but i can’t ear any sound, and the mixer seems to have lost all the panning (panning bars disappeared) and the volume faders have lost the dB scale near the fader itself.

If i play Ardour, i can’t ear any kind of sound, but if i use the Audition option inside the arrange window i can’t ear the sounds i’ve arranged…

i hope that my explaination is more clear than before!



I tried to recreate what you’re saying, meaning I made a demo project, recorded a couple tracks, added fader and panning automation, saved, and moved the whole folder to another location. When I opened it up from the new location, everything was fine for me. So, I’m gonna ask you, do you know how to set up your connections manually through jackctl? I’m assuming that’s what you’re using, although I know there’s another interface for controlling Jack on Mac OSX… either way, there should be some place where you can set up your connections manually and see what’s already connected where. Connect the output of your audio tracks to the inputs of the master track (assuming you have a master track) in Ardour. Then set the output of the master track to the input of your current playback device. I don’t mean to try and make you feel dumb, you may know all this stuff already, but just in case you overlooked something, that’s where I would start. Once you check your connections and make sure everythings hooked up to where it should be, then I would do this: highlight any track, then hit play, and make sure the meters are bouncing, and even check to see if for example the right side is higher than the left side when your pan automation calls for it. If that’s all good and there’s still no sound, repost your progress and we’ll try to help you further.
Anyway, it sounds like it’s just a connection problem because I think you said you don’t hear playback normally but when you use “audition” it works fine.
“If i play Ardour, i can’t ear any kind of sound, but if i use the Audition option inside the arrange window i can’t ear the sounds i’ve arranged…” you said “can’t” both times, but I’m assuming you meant that you CAN hear when you audition a track.
One last thing (I know this is a long post), I’m wondering why with my setup I don’t have to worry about manually connecting ins and outs if I move a project around, but you might. In Ardour, go to Options > Autoconnect and make sure you have “Auto-connect inputs to physical inputs” and also either “Auto-connect outputs to physical outputs” or “Auto-connect outputs to master bus”. I’d recommend using a master bus, it just gives you control over the final volume of your project, but it’s all up to you, it depends on your setup. I hope this helps you, and good luck!

thank you very much linucsrox, i’m really appreciating your help :slight_smile:

“If i play Ardour, i can’t ear any kind of sound, but if i use the Audition option inside the arrange window i can’t ear the sounds i’ve arranged…” you said “can’t” both times, but I’m assuming you meant that you CAN hear when you audition a track.
Yes, i would meant that i CAN :smiley: really sorry

coming back to my problem: no it surely don’t depend on physical inputs or jack routing 'cause if i set the out of the audio track to the bus master, i will not have any positive consequence…BUT, if i create a new track in the same session and connect to the master bus, i can ear the sounds coming from the arranged window with all the new automation etc…etc… so, i really can’t figure out the problem :frowning:

Now i only have to see if this happen also on my linux daw…

thank you very much :slight_smile:

Well then in that case, I wonder if this might be a bug in the Mac version, but let’s see what happens when you try it on your linux box.
This is just a random thing I want to ask, the tracks you’re playing back, do they have the record button enabled? I can’t remember specifically, but I’ve seen situations where a track won’t play back (or my keyboard won’t play through to the speakers) when the record button is enabled… something like that. But I’m sure you’ve already played around with all that stuff, I just thought I’d mention it.

ok, i’ve taken the session to my linux box and i’ve found the same situation as on Mac Osx
this is a screenshot of the arrange window and the editor mixer

thank you very much

I hate to sound stubborn, but I just want to be thorough… I noticed you have “Audio 2” selected, and on the very left hand side, where the volume meter is, the input button (near the top) says “Input” and the output button (near the bottom) says “Output.” Just for kicks, click on output, and set it to the master bus, and see if that changes anything. And by the way, I don’t know of any other way, but just in case, when you open your Ardour project from the new location, are you opening the “filename.ardour” file (where “filename” is the name of your project)? Because that file, along with “instant.xml” and “filename.history” is supposed to contain all that data about panning and gain and everything… it should have nothing to do with file structure, which means that it shouldn’t matter where the file is. So I think it’s either a bug or something specific to your setup that is causing the problem. Other than that I’m fresh out of ideas, and hopefully somebody with more knowledge about this program can help out.

Also, I made a demo project for you to download, with a little bit of automation and whatnot, just to see if it works on your system. If you’re willing to download it, it’s about 11MB. I can email it to you, just let me know.

hi linuxrox

yes, i’ve tried many times, also on Mac OsX, to set the output of the channels to master out…but nothing happens :frowning: i can’t change fader position and i can’t see and change panning controls, the audio-track only works if i create a new one… i’ve ever opened the project from the file with *.ardour extention, but i’ve always had this problem…

if you could send me your test-project it would be great, my email is

Anyway, i really can’t figure out it this is a bug or a little malpractice by me, maybe is a problem involving Osx and the session made on Osx?

I have to say, a similar thing happened to me under linux, ubuntustudio, without copying. Just today.
I don’t know what happened but suddenly all faders went away, all my recorded stereo-tracks went to monotracks, all pannnigs disappeared and all connections went away.
I tried to reconnect first in ardour (with connections and in the mixer) but that seemed to be broken. I managed to get sound back, but still everything was mono, the pannings were away etc.

Luckly I had a backup-copy of my instant.xml, .ardour and .history files. That helped, it had nothing todo with the rest of the data. Sad is, that I don’t have the broken .ardour file, so we cannot share and look.

But maybe, If you start your ardour from a terminal window, it will generate more output.

ah, that’s a good idea, having Ardour started from terminal to see what’s going on behind the scenes. Also, Franz, what do you mean when you say “i’ve ever opened the project from the file with *.ardour extention?” You’ve NEVER opened from that file, or you always have?
I will send out that email pretty soon here, let us know how it works on your machine.

i mean “i always have” referrend to the *.ardour file, sorry for my bad english :slight_smile:
Anyway, i’ve tried to open you sample project, but Ardour2 on Ubuntu 7.04 crashes…this is the output from the terminal

Loading ui configuration file /etc/ardour2/ardour2_ui.rc
theme_init() called from internal clearlooks engine!
loading system configuration file /etc/ardour2/ardour_system.rc
loading user configuration file /home/utente/.ardour2/ardour.rc
OSC @ osc.udp://utente-desktop:3819/
Enabling SSE optimized routines
ardour: [INFO]: looking for control protocols in /home/utente/.ardour2/surfaces/:/usr/lib/ardour2/surfaces/
ardour: [INFO]: Control surface protocol discovered: “Generic MIDI”
ardour: [WARNING]: Your system generates “Mod2” when the NumLock key is pressed. This can cause problems when editing so Ardour will use Mod3 to mean Meta rather than Mod2
Gtk-Message: (for origin information, set GTK_DEBUG): failed to retrieve property GtkWidget::cursor-color' of typeGdkColor’ from rc file value “((GString*) 0x885ae90)” of type `GString’
Loading session /home/utente/Desktop/sample using snapshot sample (1)
ardour: [WARNING]: unknown audio track mode “Normal” seen and ignored
ardour: [WARNING]: unknown audio track mode “Normal” seen and ignored
ardour: [WARNING]: control protocol “Mackie” is not known. Ignored
Loading history from ‘/home/utente/Desktop/sample/sample.history’.
ardour: [FATAL]: programming error: unknown file data format passed to ARDOUR_UI::map_file_data_format: 2

This seems to be a common problem. From time to time, Ardour crashes (in my case especially when I split several long regions into many parts and rearrange them) and “kills” the session file. All track inputs and outputs are lost, so you have to recreate them manually. When they are back, mixer and panning settings will be restored, but all plugin informatin is lost.

Note: This problem did not occur again after I re-installed Ardour without VST-Support. Now it sometimes crashes too (oh, time for a bug report), but the session file does not get damaged.

To me it sounds like it has something to do with your gui. I am using Gnome with 1024x768 screen resolution, and I know from skimming through the *.ardour file that it saves information about where on the screen the tracks are laid out and information like that. So I would guess there can be problems when you try to open that file under let’s say KDE using maybe 800x600 resolution. Other than screen stuff, I can’t say, because I haven’t set any particular settings other than the defualts that are set when installing PlanetCCRMA on FC6. This is disappointing…