Move to Original Position command not working here

(robinb) #1

Hi everyone. Brand new Ardour user here, so I apologise for any glaring user error-related stuff.

I’m intending to use Ardour for classical-style multi-track audio editing - grouped track work, lots of trimming and crossfades etc. Much of the audio files will have started life in Digital Performer or ProTools.

All my initial experiments and learning in Ardour5 are going good, except for one thing - I cannot get the Move to Original Position command to work correctly. The files I’m working with (WAVs and BWAVs) definitely have timestamps (they appear correctly in Ardour’s Import window), and they snap to original positions with the equivalent command in the other DAWs I have here (DP and Studio One).

When I select a region, and choose Move to Original Position (region menu or context-click), Ardour is just placing the region right at the beginning of the session timeline. What am I missing here?

Thanks!

Robin

(Seablade) #2

Sounds like a possible bug. When you get a moment can you report it to tracker.ardour.org?

    Seablade
(Seablade) #3

I should clarify, my above post assumes you are running a build from ardour.org and not from a third party such as a dirtibution repository. Otherwise you should check with a build from ardour.org first. I haven’t had a chance to confirm this behavior obviously myself

     Seablade
(Paul Davis) #4

What version of Ardour is this?

(robinb) #5

Thanks for this. It’s 5.12.0 for OS X, the standard build from the website downloaded this morning.

(Paul Davis) #6

Can you try something? Create a new session, uncheck the box in the lower right of the import dialog that is labelled “Copy files to session”, then import one of the files. Then check for the “move to original position” behaviour.

I believe there was a regression in one of the 5.x releases where when the files are “copied” (it’s not a simple file copy), the timestamp information was lost. It has subsequently been fixed for the next release.

Let us know, please.

(robinb) #7

I just tested that (and some other Import options). I haven’t repeatedly tried any of this, so I would not stake my life on these observations, but it seems:

  • If I import either to region list or to tracks with ‘Insert at file timestamp’ option, the files come in with timestamps intact and the Move to original position command works (they snap to their correct location after I drag and drop anywhere, or after I’ve manually moved the automatically placed regions). That seems to be the case whether Copy files to session is checked or not.

  • If I Insert at session start, then the files seem to lose their timestamps, regardless or whether Copy files to session is checked or not. Regions placed that way have Move to Original Position greyed out.

  • Dragging and dropping a file into a track also removes the timestamp. Move to Original Position is not greyed out for these regions, but it only moves them to 00:00:00:00. Then it’s greyed out.

I think this is right. I didn’t try the other ‘Insert at’ options by the way.

If there’s an overall fix in the pipeline, great. In the meantime I’ve discovered a way I can reconstruct my projects from the other DAWs, which is good.

Thanks for taking the trouble with this. R