Move regions vertically across tracks with Ctrl+Alt+arrow

This feature could be really useful (key-combination might not be, but any could work) to keep the region in the precisely same temporal space, but being able to move it from one track to another still. Especially useful for podcasting/montage of a feature, but probably also nice to have when editing music.

If there already exists a way to do this, please tell me how (I cannot find it in the manual)

Middle Mouse Button Click and Drag


Thanks for the reply :slight_smile:

I just tried (not with a mouse, but a trackpoint) - dragging the trackpoint towards myself/down while middle-clicking - but couldn’t make it work.
Did I misunderstand what you wrote?

With a regular drag (left-click and drag), I am able to move the region almost precisely, but the almost is my problem. It takes a while to find the exact spot again.

Can’t speak for a trackpoint, but works for me with a mouse. Maybe it is a difference in binding for the trackpoint then, do you actually have three buttons on your trackpoint (I am used to only seeing two)?

1 Like

I have three - my keyboard is the Tex Shinobi, and my regular PC’s areT430 and a T530 and both have the three buttons.

You can also use Toolbox->Slide menu The Ardour Manual

1 Like

Thanks, but this doesn’t seem to allow me to do what I initially asked for: To be able to move track vertically without having to mouse-grab them and thus risking precision in placement.

It does exactly what you asked for. Middle-button drag on a region will never alter the position in time, it only allows dragging between tracks.

1 Like

Thanks - for some reason I can’t make it work. Can it possibly be a hardware problem with trackpoints, or have i taken a wrong turn somewhere trying to follow the directions given?

Here is what I do:
Select “Slide” in the toolbar > left-click on a region with “grab”-mode active > hold middle button and drag the trackpoint “down”.
And nothing happens. - Unless I also click Ctrl while dragging, then I zoom out.

I haven’t had the chance to check in Linux yet. This is how it goes for me in Windows. Could that make a difference?

There’s no platform difference here. I’ve never used a trackpoint - perhaps someone who does can weigh in on this (though to ardour, there should be no evidence that you’re using a trackpoint instead of a mouse or a touchpad).

You are trying to drag a region to another, existing track of the same type, correct?

1 Like

Yes - that is precisely what I am trying to do. Strange that it doesn’t work… Can it be something about me having to configure the inputs and outputs to be similar for both tracks?

No, that has no effect on the drag.

1 Like

I didn’t figure it’d have either, but just wanted to make sure… - the plot thickens!

I’ll join in the hope that someone comes along with trackpoint-insight and in the meantime see if I can find my old external mouse.

Ah, you don’t need to left-click on the region at all, and holding the left button while clicking and dragging with the middle button won’t do anything. Just click and drag with the middle button

Thanks. I just tried following this advice, but when I do that, I just end up scrolling the page. The same happens when i left-click to activate the track in grab-mode.

Hmm… Seems like your trackpoint is configured to use the middle button to make it send send scroll events on movement, rather than middle-button clicks. Maybe there’s a control panel setting to change this?

Sorry, I don’t have a Trackpoint either, but:

By “Zoom Out” do you mean in the timeline direction?

If so, this seems to suggest that in this case the Trackpoint is acting as a scroll rather than a drag as that is the response you would expect from Ctrl-(middle mouse)-Scroll. Is there a way to configure that behaviour?

Gee thanks @colinf for stealing my thunder. Guess I type too slow :wink:

@paul As there are keyboard shortcuts for nudging forward/backward in the timeline is it readily feasible to “nudge” a region in the track direction (as the OP suggested)? Or could this be done with Lua (about which I know next to zero)?

Just a thought,

1 Like

Am I missing something, or why isn’t anyone mentioning Lock mode (vs Slide or Ripple)?

I thought it was the goal of this previous message Move regions vertically across tracks with Ctrl+Alt+arrow - #6 by ksawerytreningowski

1 Like

Thinkpad firmware by default interprets middle-click + hold to pan X/Y using the trackpoint.
While you can re-configure this behavior, you’re probably better off to use the trackpad for this: a 3 finger touch/press is used for middle click/press.

1 Like