monitoring output through pc

Im running Ubuntu 14 on an Asus i7 laptop. I have Ardour and Jack running.

I have connected a Zoom guitar effects box via USB which I can record and play back through the Zoom into an external amp.

I want to play back through my PC (and ultimately through bluetooth headphones connected to it).

No matter what I try, I cant get the output redirected to the PC speakers (or anywhere else). Playback is always out to the Zoom.

I have tried setting Jack output to default. I then expect it to play back through the default audio device, which at the time are the PC speakers. But output is still to the Zoom. The PC speakers will play back (from another source eg music) just fine during this.

I then try each of the outputs offered in HW-HDMI3, /dev/dsp, HW-PCH0, HW, PCH, HW-HDMI, plughw:0

But no change in Jack makes any difference to where the output goes, either during recording or playback.

Ive looked at the video tutorials, and Im at a loss to to know what Im doing wrong.

Clearly theres something I dont understand! Can someone enlighten me please?

Have you just made the changes, presumably in QJackCTL? Or have you actually stopped the Jack server, made the change, and started it again? You need to do the latter, and note that closing QJackCTL is not the same as stopping the server, there is a button to stop and start the server on the left hand side of it’s window.


See the entry on use with multiple devices. Be aware that the ALSA backend in Ardour cannot be used with multiple devices.

Thanks for the replies. I wasnt aware stopping and starting qjack wasnt the same. It turns out I was doing it correctly using the stop and start buttons though. But only by coincidence!

Thanks for the faq link - appreciated. Ive taken a read and will report back in due course. OK, so my problem is the USB interface with the Zoom on is seen as one device, and the PC speakers or bluetooth headset seen as another - namely the soundcard.

I note the difficulties in sync when using two devices. Is another option to input from the Zoom using the mic in on my PC? Then when I want to output to the PC speakers or bluetooth, it’s all through the one soundcard? I suspect this may not be possible as I was unalbe to get any sound in or out using the mic plug and speakers out.

Even if you can get it working (and there’s no reason why you shouldn’t) you probably don’t want to be using the PC’s built in mic input. They tend to be noisy, and if the Zoom’s analog output is line level it will be too high for the PC’s mic input.

OK, thanks for the help so far.

So, now I have alsa_out working (alsa_out -d hw:1) which outputs the sound through my PC speakers once I make the connections through qjack.

Im stuck on the final step, outputing through bluetooth headphones attached to the PC. aplay -l gives me:

**** List of PLAYBACK Hardware Devices **** card 0: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0] Subdevices: 1/1 Subdevice #0: subdevice #0 card 0: HDMI [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1] Subdevices: 1/1 Subdevice #0: subdevice #0 card 0: HDMI [HDA Intel HDMI], device 8: HDMI 2 [HDMI 2] Subdevices: 1/1 Subdevice #0: subdevice #0 card 1: PCH [HDA Intel PCH], device 0: ALC668 Analog [ALC668 Analog] Subdevices: 1/1 Subdevice #0: subdevice #0 card 2: CODEC [USB Audio CODEC], device 0: USB Audio [USB Audio] Subdevices: 0/1 Subdevice #0: subdevice #0

Which doesnt appear to show a bluetooth audio connection? At the time of running the command the bluetooth headphones were connected and working as tested from the Ubuntu sound panel.

So how do I go the whole mile and output to the bluetooth headphones, assuming that;s possible?

Please read the JACK FAQ link I posted above.

Thanks Paul - I did read it, that’s how I managed to get the PC speakers working at the same time as the USB Zoom output.

In the FAQ I saw this:

If you are using JACK on Linux and want to use additional devices that have ALSA driver support (i.e. most PCI, USB and Bluetooth devices), then this is the best option.

which to my read says that I can use alsa_out to output to additional devices.

When I ran up alsa_out, the output appeared on “other devices”, namely my PC speakers. So in my mind, this confirms Im on the right track as per your advice.

That info also leads me to believe I can have my bluetooth headphones as “an additional device”, since “bluetooth device” is listed.

But I cant figure out how as my bluetooth device doesnt appear as a valid output in aplay.

Sorry if Ive missed something in your link that should be giving me the answer.

Can anyone else help me make the final connection to ny bluetooth headset please?

As a recap, I have Ardour taking input from USB and outputing to my PC speakers using alsa_out. But I cant see a listing in aplay to use to send alsa_out to my bluetooth headset - even though it’s connected.