Mixing languages in Ardour UI

Hello. I’m a new user of Ardour (and Linux). Last weekend I’ been trying Ubuntu Studio (21.04) and the Ardour UI have mixed languages in some buttons or menues (English and Spanish). This is not a problem for me, I’m from Argentina (I talk spanish) but I prefer English in my software. I have unchecked “translation” option in preferences. In Ubuntu 20.04 I haven’t this issue. Any suggestion to solve this ?
ubuntu_languages

Did you get Ardour from ardour.org or from the Ubuntu repositories?

hello Paul. I’ve downloaded Ardour 6.7 from this web (ardour.org). Ubuntu Studio have Ardour 6.6… I’ve uninstalled and reinstall 6.7
Another example:
image

You’ve restarted Ardour since changing the translation preference?

Solved! The issue was fixed switching Region from Ubuntu Studio>Regional Settings>Formats. I’ve changed Argentina to USA and the UI was fixed. I use two keyboards (English as default and Spanish).
Robin, I use English language in Ardour.

image

Indeed I misunderstood. The checkbox in Ardour’s Preferences only affects Ardour’s own translation… Stock Buttons (OK, Cancel, Quit etc) can still use the system’s default.

Instead of changing your whole desktop language, you could instead start Ardour like:

LANG=en_US.UTF-8 Ardour6

(make sure that the locale “en_US.UTF-8” is enabled in /etc/locale.gen)

1 Like

Thank you Robin. I’ll try with this suggestion.