Mixing and Mastering w/o Interface Present

I created a session using the ALSA back-end and it works great with my audio interface. However if I want to go back into that session and do some mixing and mastering I can’t monitor the music without the audio interface present because Ardour takes over the entire audio system and there is no output since the interface isn’t present. Is there a way around this?

Ardour is always going to output to somewhere, check your Audio/MIDI Setup window and see what output device is selected, select the appropriate one for where you want to hear audio. If your interface isn’t there, you should be able to select where you want to hear it even so.

Thank you. I have a lot to learn about Ardour.

For playback only, you could try the “pulseaudio” backend.

Ardour’s pulseaudio backend gives no output. Neither does the JACK backend. I have PipeWire running in place of PA but I was under the impression that Ardour could still use its “pulesaudio” backend for output.

This is where Ardour on Windows excels. No issues doing what I want to do. My problem, if you can call it that, is my Linux box is much more powerful than my Windows box. I can deal with that.

Yes, pipewire emulates JACK and pulseaudio.

Ardour (or any other audio app) can not tell the difference if you use JACK or pipewire (or pulseaudio).

OK. let’s follow the signal path.

  • In Ardour’s mixer window, does the master-bus meter show a signal when you play?

  • Is the master-bus output connected?

  • Now the signal goes to pipewire… Is pipewire using the correct soundcard?
    While Ardour is running, open a terminal window and run the following command. It will not modify your system; it lists all soundcards, their current settings and applications using them.
cd /tmp && wget https://community.ardour.org/files/adevices.sh && bash ./adevices.sh
  • Next, check the soundcard’s built-in mixer: in a terminal window run alsamixer . Press <F6> to select the soundcard, <F3> to show playback volume controls. See if the mixer-faders are up, and that the output is not muted.

  • Last but not least, check cable to the amp/speakers, and if the amp is powered on.

1 Like

Thank you very much for your assistance Robin. After trying different combinations of the “virtual” sound cards in the alsamixer settings I was finally able to get output.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.