Mixbus with OBS Studio

I’m on Ubuntu 22.04 using OBS Studio and Mixbus 9.2.105 and I want to have Mixbus send its audio to OBS. OBS has a setting to use another application as a source. This works with all my apps except Mixbus and Ardour. What might be the reason?

Are you using JACK (or pipewire)? If so, you can simply add an external send from Ardour’s master bus to OBS.

I’m using Pipewire with Wireplumber. I will try your suggestion - thank you.

This is apparently beyond my limits of comprehension.

Here with Ardour 8.6 and pipewire jack, it just work. I think that it sould be the same with Mixbus

When I look at the qpwgraph there are several different OBS entries and it’s very confusing to me as to which one to use. I have a send from the master in Mixbus and no matter where I connect it in the OBS side it does not work.

But whick audio server ? Alsa ? Pipewire-jack ? With pipe-jack it should just work, without do anything. Maybe with alsa (or any non jack server) audio is locked to the audio card…

Pipewire-jack is my audio server

Ok so I got it working but it wasn’t simple (for me). Just a lot of trial and error. When viewing the qpwgraph screen, what is the difference between the two items “OBS Audio Capture” and “OBS Audio Capture Sink”?

edit . . .

Well, I did have it working. I have no idea what happened - I was about to attach my phone camera to OBS via droid-cam and realized I was getting no input to OBS from Mixbus. Playback from MB comes through OBS but the live recording does not. It did a minute ago! This is insane the way stuff just changes for no apparent reason.

I want to make a video of me playing guitar. I want to use Mixbus to both record the guitar parts and feed them into OBS. I know I can just use OBS then in post-prod I can send the audio through MB for processing, then add it back into the video in an editing program but I don’t want to go through all that hassle. I just want to set up my eq and comp in MB and have THAT feed into OBS as I play on camera. Is this impossible to achieve?

Here my connections:

Thanks but that does me absolutely no good because I have completely different systems set up. You are using pulse audio. I use pipewire/jack. The biggest thing that bothers me is how this all worked fine - then without any input from myself it just stopped working. It’s as if I had it all set up and working fine, left the room and came back to it NOT working. I’ll get it working again but man, this is as complicated as braille calculus.

Perhaps it would be easier for people to help if you posted screen captures of your qpwgraph setup so other people can also view the qpwgraph screen.

1 Like

Which version of OBS Studio? How did you install it?

The latest version (at time of typing) is which was released a few days ago.

If you installed via apt (or software centre) on Ubuntu, and the version there will probably be a lot older, possibly 25.0.3.

But, more important than the version, how you installed it could be important.

The official version from the OBS Project website installs using Flatpak where applications install into a sandboxed environment. This can make connecting from this environment to “the outside world”, which includes things like audio, a little hit and miss. Pipewire is supposed to help with this.

Either way, understanding which version you have and how you installed it might be pertinent.

I’ll post some more about my experiences with Mixbus and OBS shortly.



1 Like

I am on Kubuntu 23.04 on this machine, so Pipewire 1.0.3 is installed by default.

I installed OBS Studio 30.1.2 using Flatpak and Flathub as per the official website installation instructions. When I run Mixbus (Mixbus 10 Pro), I see the OBS inputs in the Mixbus Audio Connections, under “External” and I can connect the Master out L and R to the input_MONO:

Or, using the Routing Matrix from the Master bus output:

This seems to work for me without messing around with qpwgraph or similar, although you may need to us qpwgraph to disconnect any other mics which are connected to the OBS input.

You will need to make sure that the Input Monitoring is enabled on the recording track(s):

Expanding on this, what you are trying to do is monitor the live recording with the monitoring output going to OBS. There’s actually a fair number of options for this, and it’s best to read up on this in the manual:




pipewire-pulse for desktop audio but with Ardour I use pipewire-jack.

1 Like

Thanks Keith - lots of good information here. I’m on OBS Studio 30.1.2 and I installed it via apt.

I had my input monitoring off. That was the problem or so it seems.

The issue I have is that all these connections are made and for a while everything works as planned - then it stops for no apparent reason. What do you have set up in your OBS source for this? I’m trying to use their “Application Audio Capture - Pipewire” but that doesn’t seem to work like it is intended but it does work. Here’s what I see when I try to set it up - notice that nothing shows in the “Application” drop-down. If I have, say, VLC open, that will show up in that drop-down.:

Here is my pwgraph screen:

And here is my Mixbus Mix screen:

Both sends (one voice and one guitar) go to a single input into OBS. There will also be a video input there. Right now as I type this, everything works. If it stays that way, then all is well.

I didn’t do anything special. I just used the default source. I’ve pasted what it looks like in qpwgraph. Unfortunately, my setup is quite complex with an 18 I/O audio devices and some virtual devices to steer connections the right way, so qwpgraph gets pretty messy (IMO it doesn’t handle this very well):

I’ve added a couple of notations here showing the default connections to OBS input and output which default to my audio interface channels. Note I have not created any sources in OBS for this. These are the default ones for Mic input and Desktop Capture. For your use-case, I suspect these should be disconnected.

In my example, I have connected the master outs to the “input_MONO” representing the mic input on OBS. To be clear, I’m talking about these:

On my OBS, I don’t have the option to add “Application Audio Capture - Pipewire” which may be a consequence of using Flatpak. I can add “Jack Input Client” and, if I do, I get another client on qpwgraph which I can connect to instead:

The Mixbus Master output routing grid for this:

And, of course, I get a mixing control in OBS:

I might try reinstalling OBS via apt at some point to see what that does.



1 Like

Looking at your Mixbus Mix screen, I think the “OBS App Audio Capture Sink-51” may be the default audio input device that you get on OBS out-of-the-box before creating a Pipewire source.

The way to check this would be to remove the “Application Audio Capture - Pipewire” source from OBS and see what is left.

Out of interest, you see to be connecting the sends to OBS, rather than the Master output. Is this because you are recording a different mix from what you are outputting to your speakers?

TBH, I didn’t know you could get into the routing grid this way in Mixbus, and I’m still not sure how you did it.

I would have though, for a submix, the best approach would be to use a bus and feed the output of the bus to OBS.



I don’t see a way to remove that entry from the list of available sources in my OBS installation. On a Windows machine after you select that source another window pops up where you select the source you want to use. On Linux it apparently doesn’t do that (or anything really). I tried getting a screenshot of this list but it won’t work because the window loses focus as soon as I try to get it. If you have Pipewire running go to your “Sources” and hit “Add”. See if that is at the top of the list.

I’m not using a sub-mix. I was having trouble getting the Master out to go to OBS - kept getting the “No Align” alarm. So I assigned the two channels to each their own Mixbus then created"External Sends" on those busses. I guess I could just use one Mixbus strip and have both channels assigned to it since the feed to OBS only needs to be the total output from MB. Then I would just send the one out to OBS and simplify things a bit.

To get that routing grid I showed I simply double-click on the “Send1” and “Send2” buttons on the Mixbus strips. Those grids will pop up.


Here’s a crappy picture of my OBS Source list:

Why would you want to do that?

Or do you mean you want to remove the entry from the sources list. You do this in OBS by selecting the source and clicking on the “trash” icon:

I’m actually not sure where you got the “Application Audio Capture (Pipewire)” entry from. It doesn’t appear to be part of the standard OBS installation either on Flatpak or using the APT repository. It appears to be a separately installed plugin.

But, in any case, there’s no harm it being in the list of available sources. If you don’t want it, just ignore it.

My suggestion would be to use the Jack Input Capture source.

By the way, I have now installed OBS Studio 30.1.2 using the official APT repository from the obsproject website. The main difference I see is that, when I launch it, it doesn’t automatically create sources for “Desktop Audio” and “Mic Input” which the Flatpak version does.

Note that, on my Kubuntu 23.04 system, OBS did not recognise Pipewire Jack unless I started it as follows:
pw-jack obs

So, to use OBS with Mixbus, it should just be a case of:

  1. Create Jack Input Capture Source in OBS. Call it something useful, like “from Mixbus”:

Note I did this with 2 channels, which is the default. I left the box “Start Jack Server” unticked.

You should get something like this:

  1. I would suggest setting up a new session in Mixbus, because it looks like you’ve messed around with the settings in your current session so much, it’s going to be hard to undo those changes. In the new session, do NOT mess around with sends and stuff. Just connect the Master outputs to the OBS input.

You can do this within Mixbus by selecting the Master bus in the Edit screen, and clicking on the “Out” button:

This will pop a menu up. Select “Routing Grid” from that menu:

This will give you the Master bus routing grid. On this, select “External” from the side tab, and you should see the OBS input listed there and can link the Master out L and R to it.

That’s all you should need to do to connect things up to get the Mixbus output into OBS Studio.

You shouldn’t need to mess around with qpwgraph to get this set up, although you may need it for other routing. The qpwgraph view for this: