Midnam file doesn't seem to load

Hi all,

I’m trying to add a custom MIDNAM file for my Casio CT-S1, using The Ardour Manual - MIDNAM Reference as a guide.

There are a few problems (the guide and several files refer to online files that have been moved from http to https) and in the end I don’t get the log message indicated in the reference page I linked, and don’t see alternative patchnames available when adding a midi program change event.

Does anyone have experience / success with adding custom MIDNAM files? I’m using Ardour 7.4.0 on Linux.

Thanks in advance,

There doesn’t seem to be an easy workaround for the xmllint/https problems but if you take the existing, and supposedly working, Casio_CZ_1.midnam from the share/ardour7/patchfiles folder of your Ardour installation and modify that you should be able to get it to work.

There’s also a bit of discussion about this at the bottom of the post below

I was looking to create a midnam file to use with SFZ and DecentSampler VSTs. I needed readable names for MIDI CC numbers rather than patch files, but hopefully some of this will be useful.

The section in the Manual is useful as are several posts that you can search. I had to make a couple of modifications because of the issues you describe.

First I created a “patchfiles” directory at “~/.config/ardour7”

Finding an existing file that contain the relevant data was key. So I just tried a few from the dropdown until I found something suitable. I then copied that from “/opt/ardour/share/patchfiles/” to my new “~/.config/ardour7/patchfiles” directory.

Opening that file in a text editor you will find something like


and you need to change that to


Save that file as “your_device_your_model.midnam”. I found that I did need “_” between the 2 strings for Ardour to find the file.

Restart Ardour and check that your new file now shows up in the dropdown. Then hopefully you can go ahead with your edits.

Thanks for your help! I’ve done as you described, and it works now, I can select my Casio CT-S1 and see patch names I provided :smile:

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.