midi tracks

I’m on Ubuntu 16.04. When attempting to create a midi track, Ardour (5.8) shuts down. I didn’t find mention of that problem on the forums so I assume it comes from my system. Has someone experienced that?

I have not experienced this problem. I suggest starting Ardour from a terminal so you can see any error messages when it crashes. Also check Jack errors (for example in QJackCtl messages box, if you use QJackCtl). Are you creating a midi track with a specific plugin loaded? Try creating a midi track with no plugin loaded.

Since I upgraded to 5.8, a few days ago, I only worked with audio tracks, so I didn’t notice the problem before this morning. Reading your answer I tried to open Ardour5 from the terminal but it gives me a Ardour5 can’t be found. Did you mean Ardour4 from…. So, should I reinstall? Thank you.

Are you using Ardour from ardour.org or as supplied by Ubuntu? The latter is not supported.

From Ardour.org

Try using full path to run ardour from terminal: “/opt/Ardour-5.8.0/bin/ardour5” (or wherever you installed it on your system).

Tried the full path but no luck. Re-installed Adrou5 5.8.0 but still not able to create a midi track.

Wh are you not able to create one? Is there an error? What are you actually trying in order to create one?

Once in Ardour (any session) I simply do CTRL-SHIFT-N, and then choose MIDI TRACK. At that point Ardour shuts down. If I choose AUDIO TRACK everything is fine.

This is unreported behaviour. I’ve not heard of anyone else with this issue. Please download a debug version (nightly.ardour.org is the place to go) and read http://ardour.org/debugging_ardour … we’d like to know what is going on.

Downloaded the debug version and installed it but I can’t open ardour5 from terminal can’t find ardour5. Launched it from the desktop icon, and crashed it while attempting to create a midi track. Trying to locate the core.[pid] but no luck. I am not used to these tools so I don’t know what to do.

Many linux systems (like OS X these days) are making it harder to generate/find core files. It may be easier to use the other approach described in the debugging document (running with --debug). To do that, you need to use the full path to the program, which will be something like /opt/Ardour-5/bin/ardour5 (check for the right folder/directory name under /opt)

You might find it faster to get on IRC (links at the bottom of this page, or on the Support page linked via the Support tab above), and get immediate realtime assistance.

I have the same problem on a freshly installed AV Linux 2017.4.9 (32 bit). Creating a new audio track works fine, but when I try to create a midi track, ardour is closed. Here the output when started in a terminal:

(ardour-5.8.212:6162): Gtk-CRITICAL **: IA__gtk_tree_selection_unselect_iter: assertion ‘selection->tree_view->priv->model != NULL’ failed

(ardour-5.8.212:6162): Gtk-CRITICAL **: IA__gtk_tree_selection_unselect_iter: assertion ‘selection->tree_view->priv->model != NULL’ failed
*** Error in `/opt/Ardour-5.8.212-dbg/bin/ardour-5.8.212’: malloc(): memory corruption: 0x0d2b6bf0 ***
======= Backtrace: =========