midi sync

hey guys,
im trying to get Ardour to sync with my roland mv-8000…the mv is hooked up to usb interface emu0404.

what im trying to do is record separate tracks from the mv into ardour for some demo recordings

I did a bunch of trial and error setting changes. (mmc, mtc, turn on jack server etc. alsa sequencer, alsa raw) nothing worked though. but i really dont know what im doing…ardour recognizes the midi ports…i did the latency test from project setup and it recieved data (large jitter)

on ableton i put the mv in slave mode with midiclock enabled and it worked like that.

someone has some suggestion?


alright i got on IRC #ardour

i will ask there.

yeah I dont really get the schematics of the midi connections. I dont see the name of the emu-0404 so im just guessing which is what

ill ask again via chat another time, gotta go

i connected midi clock out to midi clock in

I think you should get on IRC. What is it that you expect the above connection to do? It takes Ardour’s own MIDI clock output and sends it back to Ardour’s input where it expects to see MIDI Clock … from somewhere else.

thanks friend,

I got the mv to function as master, at-least the transport buttons function. I dont think its syncing cause the ardour project doesnt grab the tempo and I had some other bugs. no luck with slavemode.

im terrible with this kind of technical troubleshooting… i tried what you said though I think, midiclock enabled in ardour and on the mv, mv in slavemode, and in midi connections from “misc tab” > ardour misc i connected midi clock out to midi clock in. the midi clock stays ‘pending’ ive tried just about every option though cause I noticed with the mv as master you just click the connection and the clock starts running…to no avail.

Ill just keep chipping away at the problem and otherwise I use internal mixdown on the mv.and import the tracks. it sucks workflow wise but at least its dependable. maybe the emu is at fault, it was a nightmare on win 10 too.

thanks again for the assistance

You don’t need Ardour to generate MIDI Clock. You want to sync to an external MIDI Clock source, not send MIDI Clock somewhere else. Disable the MIDI Clock generator option.

The ALSA sequencer backend is typically the best choice, but if your using Ardour’s own ALSA audio/MIDI support, then the raw/sequencer choice doesn’t make difference.

This is the sort of problem best discussed in real time on IRC rather a web forum.

thanks…that narrows it down a bit as far as which sync method, from the mv part i got this, im afraid I need something more specific though from start of the project…midi raw or sequencer? in edit/preferences which midi settings do I tick? i have ardour on midi clock and enabled mclk generator (saw that suggestion in a similar topic but it might be useless)

in window/midi connections i dont really get which things I need to tick and which ones i need to leave alone both misc and hardware main menus expand up in misc and hardware sub menus with similar settings that don’t seem to correspond with each other.

following your instructions its clear that the mv receives midi cause i see the led lighting up but thats it. I cant get the mv to dance with ardour

You need to use MIDI Clock. MMC and MTC have nothing to do with MIDI clock. I also suggest that you stop using JACK and use Ardour’s own ALSA audio/MIDI backend. It will be a lot simpler that way.

You need to ensure that your MV-8000 MIDI out is connected to Ardour’s MIDI clock input. Then you need to make sure that the external positional sync reference is MIDI clock.

and I enabled external positional sync… if gave ‘pending’

I guess i got some success while playing around with the midi connections in ardour which made the roland go crazy and crash…:wink: but at least something happened.