Midi regions - only play top layer

Hello you,

I want to add triggers for the bass drum to my acoustic drums.
In addition to my audio tracks, I create a MIDI track.

Now I re-record the song or parts of it again and again until I am satisfied with the recording.

My problem is that Ardor plays all layers at the same time for the MIDI regions (not just the top layer, as is the case with the audio tracks).

Of course that sounds terrible.
Is there a setting for midi tracks where only the top layer of regions is played?

It would be very inconvenient to manually mute all lower layers.

Many thanks for your help!

It is a per region setting. Select region(s) and use global menu (or right-click on a region):

Region > Gain > Opaque

If a region is transparent (not opaque), underlying regions are audible.

PS.
When you record MIDI, the Record Mode setting matted (top-leftish in the toolbar) pick “Layered” image see the tooltip for explanation.

When drawing MIDI Regions, you can pick the default in Session > Properties > MIDI > Draw tool creates opaque MIDI regions.

1 Like

Thank you for your quick answer!

Unfortunately my midi regions do not respond to the “Transparent” or “Opaque” setting. No matter how I set it, they always remain transparent (even if “Opaque” is checked).
(The audio regions respond to these settings)

Your tip to set the recording mode to “Draw” would theoretically work, but I don’t want to lose the old regions.
I just want to ensure that only the upper region is played.

My pragmatic but not smart solution would be to mute the entire midi track until I’m happy with my recordings. Then I have to cut the layers so that they don’t overlap. That doesn’t sound like fun. :confused:

P.S. I use Ardour 6.9.0~ds0 on Ubuntu 22.04

That’s almost certainly your issue. Current release is 8.2 …

1 Like

Yes, I found this and have some hope that the problem is now solved and I just have to install a new version of Ardour.

https://tracker.ardour.org/view.php?id=5100

Thank you all!

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.