Midi out from my plugin via IAC

I have created a AU plugin that writes to midi output. Then, via IAC (I am on OS X) the notes should go to my softsynt (A Pyo Python app). This setup works in Reaper, but not in Ardour.
I just record a midi track and try to play it back. The notes are visible in the track, but there is no output…

Richard

have you checked which MIDI channel those notes are written to and what channel your soft synth is reading?

Yes, midiout goes to channel 1, the softsynth reads all channels…

Can you send a screenshot of your mixer window?

Sure, here it is…

You seem to have been toying with plugin pin-connections:
The MIDI input is bypassed around the plugin. The plugin’s MIDI input is not connected.

Check “Pin connections” (context menu of the processor, or in the plugin’s generic control GUI).

That is correct. I have it back now to go to the plugin input. Still no luck…
I tried with disk on or off as well

I don’t know exactly what “IAC Driver” is but it sounds it is something like a MIDI-version of an external (to Ardour) ASIO software. Is the “IAC Driver IAC Bus 1” that the track is routing to a Bus within Ardour or an input to this external software? If the first is the case, do you have that Bus routed to the master channel? If the latter, do you have IAC routing the softsynth output back into Ardour?

Pin connection is definitely the reason why the plugin receives no input. See the red vertical “GND” feeding the plugin’s MIDI in:

image

Maybe remove and re-add the plugin, or create a new MIDI track. It should auto-connect MIDI in by default.

PS. Python isn’t realtime-safe and should not be used for DSP code. The python interpreter has a global lock for garbage collection. There are guarantees that it can complete processing within an upper time bound.

I think I tried all that.
Well, the Pyo library by Olivier Belanger is an amazing library that allows you to create synthesizers and effects with real-time performance. Of course most of it is written in C. My plugin is created with Cabbage and it contains some Csound code to pass the midi to midiout and/or OSC. When I tried it with OSC only it was not fast enough. With midi over the IAC bus it is excellent, at least in Reaper…

Very strange, Ardour does not automatically create pin-connections as shown in your screenshot, also the default is to just take MIDI input from either hardware devices or data from disk.

After re-setting connections, does the plugin create sound when you play MIDI data?

The plugin cannot play sound. It only outputs midi data. Now I have changed the plugin form being an AU to a VST. The connections show different and I see midi output. (See the screenshot), but nothing is heard from my softsynth…

IAC is a midi bus. I do not have to route back the audio into Ardour, since my softsynth generates sound by itself.