MIDI one direction

Hi all.
I have a kind of issue, or better a half issue. I connected my keyboard today to check if MIDI worked. It did but…
I just connected one cable to the keyboard MIDI out.
It goes to the Fast Track MIDI in.
The Fast Track is connected to che computer via usb.
My headphones goes into the Fast Track.
The MIDI track I created in Ardour works, I can hear the sound. But when I play the other tracks I’ve already recorded to adjust the piano part, I cannot hear the sound in the MIDI track anymore. It shouldn’t depend on the fact I haven’t the other MIDI cable coming from the Fast Track MIDI out to the keyboard MIDI in, since I hear what’s going on inside the headphone connected to the Fast Track. Is this right? What might be the reason why I cannot hear any sound in the MIDI track when the other tracks are playing? Thank you all.

Have you confirmed that midi events are actually captured on the track? It might be that you have the midi and audio properly set up to play sound when you hit keys on the piano, but maybe you haven’t enabled the track to record.

In Ardour at present, there is always a choice of what is heard from the outputs of a track: either the material stored on disk and referred to by the track’s playlist OR the inputs to the track. There are a lot of different ways to control which of these two is heard and when, but the default is pretty simple: when the transport is rolling (“playing”), tracks that are not record-enabled playback material from disk. When the transport is stopped, tracks that are not rec-enabled playback their input. You can manually override this using the “In” and “Disk” buttons in the mixer strip for each track.

For MIDI, many people seem to expect what has traditionally been called “cue monitoring”, where a MIDI track will playback both its input and the material referenced by its playlist; Ardour cannot do this at present.

@ Michael: of course the track was armed and ready to record

@ Paul: I don’t think I understand all you said, sorry but I’m quite newbie. I’m trying to explain myself better. I have a certain number of tracks already recorded. I want to add a guitar track. I add a track, arm it up and start recording it. While I’m recording it, the other tracks already recorded playback what it is in each track, so I can hear what I’m doing, how and when. You mean with MIDI I cannot record in this way? If so, how can I hear what I’m playing and in which point of the record?

Note that for your audio description you say “I add a track, arm it up [ …] while i’m recording it, the other tracks already recorded playback what is in each track”.

The same is true for MIDI and Audio: if you add a new track, you will be able to hear what is in the other tracks while you record into the new one. But you cannot hear what is already in the track you are recording into.

The problem here is that many people want to do overdubs of MIDI tracks in which they hear the existing state of the MIDI track, even as they record “over it”. They do not do this with audio, and currently Ardour uses the same model for both audio and MIDI.

Not easy to explain it seems. It’s surely me.
I cannot hear what’s in the new MIDI track if I haven’t recorded anything yet. The track was pretty new.
Beside the low sound level, the problem is I can hear what I’m playing while the track is armed and ready to start. But when I click PLAY with both the recording buttons on, I don’t hear what I’m playing anymore. I’m always talking about the MIDI track. The other audio tracks are playing without any problems and I actually hear them.
Abut the other issue: how can I get rid of the window appearing continously? The one about subscription.

I don’t know which “subscription” window you mean. If it one about silence, that means you are using a free demo version. You would need to get the full version. If you mean the one that shows up after an export, that has the option “Never ask me about this again”.

I think you’d be better off discussing this on IRC. Solving your issue/understanding is going to be much, much faster with realtime communication. Best time is 09:00 to 23:30 UTC plus or minus a few hours.

Yes, silence one. Anyways let me see how IRC works (which I’ve never used) and I’ll see you there, even because I’ve never received your email.

telover you can get to IRC through a web browser by clicking on the link at the bottom of these pages…
(Says ‘#ardour at irc.freenode.net’)