Midi Maps work differently in Win vs Linux

I have a Rodecaster Duo which is not listed in the Control Surfaces list so I wrote a midi map to use with it. I use three of the smart pads on the Duo to control the recording operations. One pad starts the transport, one stops it and the other one send the play head back to zero. These work well for me on the Windows 10 version of Ardour 7. However on the Linux (Ubuntu 22.04) version, the command to stop the transport also sends it back to zero, which is not something I want it to do. The map is as follows:

<?xml version="1.0" encoding="UTF-8"?>
<ArdourMIDIBindings version="1.0.0" name="RCD MIDI Bindings">
	<Binding channel="1" note="14" function="transport-stop"/>
	<Binding channel="1" note="13" function="transport-roll"/>
	<Binding channel="1" note="12" function="transport-start"/>

The smart pads on the Duo are programmed as follows:
Type = Note, Note = 14 (or 12 or 13), Channel = 1, Momentary rather than latching and sends both press and release.

The “Transport Stop” binding does indeed stop the transport but it also sends it to the zero point. Is this simply a bug in the midi functionality? As I mentioned above this map works perfectly in the Windows version of Ardour 7.

The midi tracer indicates all button presses are working as programmed. This image represents three button pushes, one for each of the buttons I have programmed - Start - Stop - Return to Zero.

Can anyone address this?
Thank you.
Dave S.

It sounds as if you’ve simply got a setting like “Auto Return” enabled on Linux and not on Windows. I cannot think of a reason why that sequence of MIDI messages would cause the playhead to jump back to zero, given your MIDI binding map.

Bingo!! Thank you Paul! Now that I have turned off auto return, the “transport-start” command doesn’t work so I changed it to “transport-zero” and that doesn’t work either. Is there some other setting? I pored through the menus and couldn’t find anything pertinent.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.