Midi mapping encoders (Behringer CMD DV-1)

Hey y’all,

I’m trying to configure my hardware controller, but i can’t get the encoders working…

Sorry for the lengthy post!


  • Ubuntu Studio 15.10 (i quickly tried it on KXstudio with identical results)
  • Ardour 4.1.0
  • Behringer CMD DV-1 (2x, each sending on it’s own channel of course)

Using Midi learning:

The “note on”-events of the pads are mapped without problem, and the encoders behave as expected. Ardour interprets the signals (should be enc-b type, the encoders sent either 65 or 63 as data byte) as normal ctl-message and moves for example the pandirection from 50 to 51 percent. The faders on the other hand don’t seem to move at all.

Using midi map:

So i wrote my first midi map, trying every encoder type:

Ardour recognises both the midi input (as shown in midi tracer

as well as the map and the transport controls again work, although a bit different than through midi learning. The transport-stop message moves the playhead back to zero instead of just stopping playback. Is that normal?

But the encoders don’t work at all.

Hopefully it’s just my stupidity.
Thanks in advance!,


Encoders were added in version 4.2, so they won’t work in 4.1. The latest version is is 4.4… probably 4.5 by the time you see this :slight_smile:

if you do not like that stop goes to start, you can use an action instead. -> action=“Transport/Stop” may work differently. Or set your play button to action=“Transport//ToggleRoll”. Action names can be found in ~/.config/ardour4/ardour.bindings (may be ardour.bindings.old) or at the bottom of http://manual.ardour.org/using-control-surfaces/controlling-ardour-with-osc/

Thank you lenovens! you solved everything!!!