Midi learn in cue grid

Hi all! I trying to get my head around how to fire a midi clip in the cue grid via midi controller. I have connected a foot controller and selected it as midi input for a soft synth track (midi input seems to work fine).
Now in the cue grid, i dragged a midi clip on the synth track and it sounds like expected when i click the cell’s play symbol, but when i want to use the midi controller, nothing happens when i use midi learn. Afaik i have to use a note on event, so i set up the controller swith to send a note on event for midi note 70 and a velocity value of 100. The synth then plays the note (which i don’t want It to, by the way) but the midi clip wont start playing.
I hope, someone can help me there, and sorry for my poor english. :wink:

Ah, okay, i figured out that there’s a “cue control in” which i can connect my foot controller to via the QjackCtl connection graph. But until now, i couldn’t find a way to do this inside ardour. Can sombody enlight me, how to get this working inside ardour without QjackCtl?

Thanks for your research, as I was facing the same problem.

I was able to use the “MIDI Connection Manager”, under the menu “Window”, to connect the MIDI controller (tab “Hardware” on the left) to the cue control in (tab “Ardour Misc” at the bottom). I hope that helps.

1 Like

Thanks Bruno. This is exactly what I was looking for.

Thanks for that tip, now I was able to launch a single clip from a midi note from my MalletStation. How can I do the same thing to launch an entire cue? Is that not set up yet? right clicking on the letters doesn’t offer midi learn.

Correct, not currently possible via MIDI learn.

Actions for this are defined, so you could write a MIDI binding map to “permanently” map a given pad/key/whatever to a given cue.

Hi Paul,
At the moment I have to use an old macbook air OS11 from 2013 because
the MalletStation Webmidi software doesn’t work on linux. I made a MIDI
binding map called malletstat-midi-plan.map and put it in
$HOME/.Library/Preferences/Ardour8/midi_maps/ I had to make the
midi_maps directory myself. The map is below -

I don’t know how to get Ardour to load it. I can do Preferences/control
surfaces/generic midi/show protocol but under MIDI Bindings it doesn’t
show up. I did restart Ardour, of course. I also tried putting the map
in the Ardour8 directory. On top of that I might have mistakes in the
map itself…
Any tips? Thanks

In the end, of this phase anyway, I had to send back the MalletStation so instead I continued with my Korg Nanokontroller2. Very nice that there is already a midi map for it, so I copied it from GitHub or where ever that was and set about trying to map the first two Solo buttons to the cues A and B, just to make sure I could do it. Trick one - cue A is number 0, cue B is number 1, cue C is two…
It would be great if there were more places to find the necessary code for the cues on the Ardour website, I only found it in the what’s new of 7.2 Ardour.
As instructed, I stuck the midi map in LInux ~/me/.config/ardour8/midi_maps
I didn’t do the stop the cue yet for a different button, but here is a png of the first two groupings for the Nano, the original line is commented out -

Cheers,
Adam