MIDI keyboard controller help please

Hi all,
Is it possible to use a legacy M-Audio Radium 49 keyboard controller with Ardour? I’ve been trying to do so without any success. I’ve read thru many posts and web stuff, but can’t find any answers for my situation.

I’ve tried using other bindings of other M-audio keyboards in the generic MIDI list, but that still doesn’t work. This legacy USB controller seems to be not detected by anything. Only my PreSonus Faderport2 is recognized in the MIDI patch bays.

Thank you,


Did you thicked the midi ports of your keyboard in the setup to make the keyboard avilable in the routing?

A keyboard doesnt need mapping, only controllers do.

Thus said if your keyboard has some controllers and no mapping ut should work anyway by enabling generic midi without and manually mapping the desired controls.

if you are using Jack, launch “a2jmidid -e” in a terminal may help

Sahaathyva: Ok, I don’t need to use all the controller stuff on this old keyboard controller. I just need the keyboard. So, If I don’t really need mapping, this is good news.

stratojaune: Thank you for sharing that. Not sure what this does, but I’ll look into it.

Thank you so much.

Well…usb MIDI is hard right now. :thinking:

I’ve been going with what Paul has stated in other posts and thus, I use ALSA. Has been great for everything I do so far. For some reason it will not recognize that my keyboard is even there. Not even as a generic device. I’ve tried all the above suggestions shared. Going the JACK route didn’t work either. I know I must be doing it all wrong. Heading back to internet land and learn me some things…

serdeman: sorry I was a bit light… more details:
a2jmidid can be found as a Debian package, and surely else where. once
installed, plug in your device and start Ardour with Jack audio engine.
launch in a terminal “a2jmidid -e”: it makes connections possible both
in QJackCtrl and Ardour.
if you are using Ardour with Alsa you could find your device in the
input of MIDI tracks (if you don’t choose “none” in the alsa MIDI
driver -bottom- section of the Ardour session “engine” settings)

Thank you, stratojaune, for the details! That’s exactly the kind of stuff that helps people like me!

Soooo, after some digging, I went to my software manager for my Linux distro, and just to see what would pop up, I typed in “M-Audio”. Wow, the first item was a driver needed that just happened to have my specific legacy keyboard in its code. So, apparently, it stated that without this driver, the Linux system would not be able to access this device (and a few others on the list too).

I installed this driver and FINALLY the system recognized my keyboard!!

Now that all is working, I just need to find the best settings that get me the kind of performance I need without all the Xruns.

Thank you so much

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.