MIDI keyboard controll channel 1 always


(dacr) #1

Hi,

I use a MIDI keyboard as input, it work channel 1 only, and I use an external synth module as output.

Start method:

  1. qjackctl
  2. a2jmidid -e
  3. ardour

I make 2 MIDI track (in synth module I set channel 1 as Piano, channel 2 as Bass). In Ardour in the selected track I set inbound “Force all channels to 1 channel”, and set playback “Use a single fixed channel for all playback” to channel 2. I set MIDI input to MIDI keyboard, output to synth module.

If I put a key in piano roll then synth module play the sound with Bass.
If I put a key in MIDI keyboard then synth module play the sound with Piano.

Why?

Thank you for help!
David


(dacr) #2

If I use direct with ALSA (without Jack), result is same.


(Robin Gareus) #3

This is only used during playback, when Ardour reads MIDI-data from disk. It does not affect any live input signal.

This setting does affect live MIDI-data directly on the input. It is relevant for both: data to be recorded, as well as data that is passed through.


(dacr) #4

Thank you! And what is the solution? Example it is working fine in Cubase. Can I route input MIDI channel to output channel of selected track?


(dacr) #5

I have a solution:

_midi_fix_channel.lua

But not a nice solution.


(Robin Gareus) #6

I think I’m missing something. Would you mind to elaborate: What is the actual goal that you do want to achieve?

Ardour doesn’t have concepts of “input channel” and “output channel”. Any MIDI track does record and play all 16 MIDI channels at the same time.


(dacr) #7

The goal is that if I change a track in Ardour then it will change the output MIDI channel. Like the all of DAW :slight_smile: It is an unwritten rule.


(Robin Gareus) #8

I suggest to only set the inbound filter per track, then. Since the track will always only receive the given channel, by induction, that also changes the output.

In any case you probably want a couple of MIDI tracks without instrument, routed to a MIDI-bus with the instrument. Then use Preferences > MIDI Ports > MIDI Input follows track selection