MIDI Key-range filter doesn't have all keys.

I was planning to use MIDI Key-Range filter as a way to make a drum mixer for my Roland td 11.
But i found that when I used the scrollwheel to set lowest and highest note I couldn’t get all of them. D, F, G#, and B was missing.

Is it a bug or am I just stupid (that’s allways a possibility), or is there somekind of workaround.

I tried downloading and replacing the x-42-midifilterpackages if the ones in the repos was old or something, but it didn’t help.


I have this same problem too. I noticed it first back in July when I was editing a downloaded MIDI file. I worked around it by moving the notes manually. It was painful, to say the least! I guess it has not yet been examined by x42, or he cannot reproduce the same issue. I have not really done anything since then. No time :frowning:

Oh, another thought on the subject. I first thought the instrument patch I was using just didn’t have the range for the octave I was trying to obtain, but since I was able to play those notes on a MIDI keyboard using the same patch, that was obviously not the problem. Have you checked to see if that could be the case in your instrument?

It’s a bug in the “ClickBox” in Ardour’s generic plugin GUI that has been around since a while (Ardour 5.5ish) and has meanwhile been fixed, but didn’t make it into the 5.12 release.

This affects all integer-step controls for all plugins in the Ardour-provided Generic-UI. You can work-around this by using the slider (or numeric-entry) in the Editor Automation Lane for the given control, or use the mixer-strip inline-slider. I’m sorry for the inconvenience.

Thanks for the reply x42. If I were to build the latest Ardour from git, would the fix be included there?

@Lexridge: yes, but you do not want to use current git. it is undergoing a major overhaul (6.0-pre0) and is not ready to be used, except for throw-away sessions and testing:

Haha! I read this too late. I discovered last night that 6.0pre was presently in the git, after I pulled it. It’s okay however, although it did build without errors, I didn’t install it and I still am running the 5.12 build from a few weeks ago. I have not yet done a project with it but I will test it out soon.

Oh, btw, when will this fix trickle down to Mixbus, or has it already?