MIDI Key Filter Plugin doesn't show

As many other users, I’m having a hard time using Ardour to deal with MIDI (recorded from E-drums).

I’m trying to use the MIDI Key Filter to split each instrument to a different track (i.e. snare, tons, splash, each with their own dedicated MIDI track for later individual processing). x42-plugins is installed in /usr/lib/lv2/midifilters.lv2 directory, Ardour finds it (i.e. if I delete it, several MIDI-related plugins disappear) but specifically “MIDI Key Filter” does not show in the list of plugins by Ardour.
OS: Ubuntu 20.04, Ardour-5.12.0
I’ve tried reinstalling the x42-plugins or downloading it from the github page and installing manually. Ardour finds several of the MIDI plugins, but “MIDI Key Filter” is nowhere to be found.

Any ideas on how to solve that?

There’s only “MIDI Key-Range Filter” as part of the x42 MIDI Filter Collection

Setting min == max and “Include Range” will only pass the given note, here a C4:

In that case you may also have to show “Utils” in the plugin-manager. You may however want to do yourself a favor and update to Ardour 6.8, especially when working with MIDI.

Welp, I had completely missed the “Utils” option.

Upon testing it seems like it was all in vain. I can get each instrument to play in a different track, but when I try to record, all tracks record all instruments. That completely defeats the purpose.

Thanks anyway.

Again upgrade to v6 where you can place the filter before the recorder.


I don’t get what you mean.
I am using Ardour6 now and I can’t see such an option.

Search the manual for “wet recording” or “disk I/O”. It’s available from the mixer strip’s processor-box context menu:

For MIDI, with “custom” position, it looks like:

here the “MIDI chord” plugin runs first, processes the live input signal and its output is recorded. On playback it has no effect, the “player” is after that plugin and only feeds the synth.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.