MIDI input config. Missing "sync" section in preferences. Something not compiled?

Just compiled ardour with:

./waf configure --libjack=weak --with-backends=jack,alsa,dummy --cxx11 --strict --optimize

In my Edit → Preferences dialogue I see a MIDI section, with Virtual Keyboard settings.
Under “MIDI” there’s a “MIDI Port Config”. When I click there, the details part of the dialogue is blank.

Searching for selection of external midi controller configuration, not finding.

Also, in the preferences dialogue I am missing a “Sync” section, like I see some demo videos are showing.

Did I not compile something in, with proper configure options?

Also, would like to know more about “sync” and how to sync other apps

Things change. You want Edit > Preferences > Transport

If i was to guess you just built git/master which means you built an unreleased version of the application. You can’t expect to find tutorials on old versions matching this.

This is what I see in my Edit → Preferences → Transport:

I don’t see a MIDI input selector.

I don’t see one under “Chase” or “Generate” either

It doesn’t work that way anymore.

Chase → Show Transport Masters Window (or access it via the top level Window menu)

That’s where you can configure a given transport protocol (and connect it)

Looks like I need to RTFM.

“MIDI Clock” is the new way of saying “MIDI” ? I still don’t see my external devices listed in any of dropdowns in “Transport Masters Window”.

Maybe my JACK is not properly connected. By the way - i don’t see Ardour showing in my JACK graph window … and no explicit connections.

Perhaps someone could provide a doc reference.

(And I like the aggressive reorganizing of menu - indicative of a robust development process!)

Thanks

Ooops. I can’t believe it. I spoke too soon. Somehow Ardour appeared in my JACK - after I posted above. With a whole bunch of sub ports to connect to. Will try to connect now.