Midi from Musescore no sound?

I imported midi files exported from Musescore, but there’s no sound coming out. I’ve tried Fluidsynth and Zynaddsubfx and there’s no sound on both.
The midi file has instrument in its automation, but deleting it doesn’t change anything. Can anyone help me? Thanks :slightly_smiling_face:

Do you get sound if you just add some midi notes on a MIDI track and select GM Midi synth?

Yes I do get sound if I create the notes from scratch in Ardour.

MuseScore always puts a controller, a clef and a key change message into the MIDI files.
I actually used Rosegarden to import those files, deleted the three entries from the MIDI file and re-exported the file from Rosegarden.
Those files play fine in Ardour.

1 Like

Ahh I see. How do I delete those three entries? Which menu do I need to look into in Rosegarden? I’m not familiar with it.

Open the file with Rosegarden, right-click on the yellow MIDI-track, select “Open in Event-List-Editor” there you can just select all non-note events and delete them.
After that, close the editor and export the MIDI file. File/Export/Export Midi-File"
I always delete all tracks that I don’t need, so that I have only one channel in my exported MIDI-files.
I usually split all instruments to different MIDI-tracks in Ardour.

1 Like

Just to be clear, there is no such thing as a “clef” or a “key change” message in Standard MIDI Format (SMF) files. There are program change messages, but those relate to the timbre of the sound that the instrument might generate.

Just tried it and it works! Thank you so much :grinning_face_with_smiling_eyes: