MIDI device not showing on Mixer Channel

When I click on the Mixer strip MIDI device, I am unable to see The AK Midi In. Any suggestions to allow this device to be selected?


Check Edit > Preferences > MIDI > MIDI Port Config

If you marked the Audio Kontrol 1 for “control only”, it won’t show up as a track input (because you’ve told Ardour it’s not intended for that purpose);

BTW, with many new MIDI devices that combine a few-octave kbd, pads, knobs and buttons, it’s really impossible for Ardour to make a sensible default for this setting.

Thank you! That was the problem!

Could the tool-tip be appended to indicate that it will not be available as a MIDI input via the mixer ? I checked both, because I assumed that checking ‘Control Data’ would allow more MIDI codes to flow through ( CC, PC, maybe MOD and Pitch as well). ‘Music Data’ to me meant the notes (on/off), and likley mod, pb, velocity, and after-touch.

After reading more on the forum, it seems there is no filtering going on. I could not find specifics in the manual, but it slightly implied filtering.


This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.