MIDI data not read

I have been using Ardour for 10 months or so. I upgraded to ardour 3.5.357 and started using the midi portion. I enter notes with the piano roll single not entry. Well I composed a bass track of 200 some measures just fine. Problem is it is no longer being read by the program. The individual segments of the track are in the file system, where they were created, and they show up in the “Regions” location in the window, but they no longer show up in the track where they were created, thus have no function. It seems like the code that finds the segments (I use the term segment due to not having any other word to identify them. I guess they are actually small midi files, having a duration of one measure in this “Session”) places them in the midi track to reproduce sound when transport begins, that code seems to have lost the location of these midi files. Now that is what I believe, but I have very little understanding of how these pieces of software really work, nor do I actually care, if they work correctly. The Wav files for the same session always work correctly, but I know that is fully a different kind of file.

Any idea how to I can get these midi files to function as they originally did?

Any help would be appreciated. It takes hours to go through single note placement for these kinds of tasks. I don’t wish to invent this wheel again, only to find the same issue afterward occurring again. It happened before.

I am using Xubuntu 12.04 64 bit desktop with KXStudio repos added.

Have you read http://ardour.org/whatsnew.html ? It doesn’t answer your question but it is rather important.

I have read it now! The packages for 3.5.403 are not available in either available updates, or the software distribution points that function with the OS I use. I know how to upgrade yet man what a nightmare that is. I guess I shall have to. Again the date remains in my file system. I have no way of knowing if the data is corrupt, which may actually be the issue. In looking at the content available through the regions tab, it looks to be whole and complete (though I question my own analysis).

Thanks for the link.

We do not support distribution-built versions of Ardour. http://ardour.org/download provides ready-to-run versions of Ardour that will run on almost all Linux distributions.

If you can package up your entire session and send it to me (paul@linuxaudiosystems.com) I can see what I can do with it.

its been said many times in the forums that midi work still has some bugs, i get the same thing, midi regions disapear or ardour looks for regions that dont exist and the original midi files are there.

i havnt tried midi in the recent update so maybe its better but ardours main functionality is audio which is hte most important part midi is at the moment a bonus.preview

Thanks for the offer to look! Since reading the article http://ardour.org/whatsnew.html I decided I should upgrade because version 3.5.403 is unavailable through the software distribution software in my system. I am not sharp enough to load stuff through the command line interface. Well in the process, I erred and wiped a wanted partition from my hard disk, so the data is gone, no backup. Silly I know. Lazy. Not a great loss in reality though. Anyhow, thanks again.

I may have to figure a different program for midi in the future, if this is a consistent issue. I have done the same things with Cakewalk for years, but gave up windows in 2006 except for that DAW on Win 98 SE. It’s too archaic now, so Linux is my new way. Still a lot to learn. Cakewalk was so smooth and easy to use. Quite like Ardour for the audio portion in it.

Carry on!

We are working on MIDI all the time, to a greater or lesser extent. I have written elsewhere about what caused the issues with data loss, since it was quite an interesting software design and implementation example, but not of much interest to end users. There is quite a lot going on with MIDI right now in fact. In general the idea that Ardour is “the way it is now” at any point in time is a fundamental mistake. The program dynamically evolves on a day-to-day, week-to-week, month-to-month basis. There has not been a release for some time of our new version because the changes there were pretty substantive and it has taken a long time to clean up all the side effects of the new graphics implementation.

I have no idea how or why you could wipe out a partition while installing a tarball of Ardour, but I am sorry for your loss.

I was loading a new version of xubuntu to create a new system, I put it on a 1 Tb HDD that i have been using for just a couple of months. On it I had two partitions, one for the OS and another for my own data. I am highly dyslexic so reading is not my friend and I miss read somehing, Just a silly error. Most of my data is backed up on a different HDD.
I must say I like Ardour in general. Thanks for the effort! Thanks for helping me out.

Not to say that XUbuntu is not good, but you could have quicker a smile on your face if you use a specialised distro, like AV Linux or else… You can check distrowatch to make your choice :



I know it’s quite an old post but the initial description is exactly my problem.

I’m using UbuntuStudio with Ardour 4.2 (subscriber) and I recently started to use Ardour to make symphonic arrangements. I use 49 MIDI tracks and 49 audio tracks. It seems to me that the first 10 MIDI tracks cannot save the regions on the tracks. My regions still exists in region list and I don’t get any error at start. I already tried to replace again all my region on the right track and save, but on next loading there have disappear from tracks.

Also other bugs: “Bounce” doesn’t work for MIDI region. Nothing happens when I try to bounce some MIDI region together. I have some regions on a MIDI track. Once I closed and loaded again my session, it appeared a copy of these regions on the MIDI track underneath. Impossible to delete or remove without deleting or remove the orginal regions. I tried the “Unlink from other copies”, but Ardour crashed.

Thanks for your help!


Please report these bugs on tracker.ardour.org, and please attach the session file (.ardour) to the report. It would be even better if you could possibly attach an archive (tar) of the entire session.

The forums are not a useful place for handling bugs like this. Thanks for your help in getting this tracked down.