Midi Control In - issues with jumping values?

Hey there.

Love ardour and have been trying to integrate it into a live performance. Thanks for all the work ya’ll have done on it!

I have an issue when I have midi-learned some parameters (for a slider on an eq in this case).

It works for the most part, but if I try to jump values or change them at more than a very moderate pace then ardour will ignore the cc midi messages until I return the slider to the position at which ardour seems to have ‘lost’ track of the changing values.

Is this intentional or something? just trying to figure out how I could jump values because it’s a very useful feature for me. I’ve tried it on different midi devices too just to make sure, it is a consistent issue. Thanks for any input, much appreciated!

1 Like

pretty much intentional. In preferences->Control surfaces->highlight the generic midi and then at the bottom of the box there is a button for “Show protocol settings”. the two settings that may be of help to you are the “Motorized” check box (turns this action right off) and the “Smoothing” setting. The smoothing setting determines how far away the next midi value input can be away from the last to be considered part of the same move.
Do note that if the setting is changed via the GUI to outside the smoothing value, moving the control towards the actual value will still be required.
For most cases, the user does not expect the value to jump to a new value but rather move smoothly to get there. In your case you prefer the jump and so turning smoothing off may be the right choice.


thank you for the details! very helpful, I appreciate it - I’ll check out those protocol settings and try to optimize, appreciate it

actually really glad someone asked this and that someone else answered. I have this issue with the faderport from time to time. Ill check the setting and see if its helps.

1 Like