Midi cc assignment

i’m new to Ardour and i’m testing it on Fedora 13 32bit.
I have done all midi connections between Ardour and my midi device using qjackctl(the midi device is the emu xboard 25) and i have chosen “generic midi” as control surface in Ardour.
The Ardour version is 2.8.11 and i’m asking for something of obvious, but the only related guide found is the one from this link http://www.ardour.org/files/manual/sn-bcf2000.html and there is a point on the guide where it’s written:

We want to map the Master fader in Ardour to the first slider on the BCF. Hold down the Ctrl key on your keyboard, and click with Button2 on the Master fader in Ardour. You should see the operate MIDI controller now. Move the first slider on the BCF up or down a bit. The window should disappear, and you should see the master fader move up and down as you move the slider on the BCF.
It seems to be explained for OSX users, because i'm unable to click with Button2 of the mouse and i don't know which key combination to use on Linux with PC mouse and keyboard for the operate MIDI controller now window to be appeared, so i need a suggestion on how to accomplish this simple step. Thank You Sal

got it,
it was the middle mouse button, so ctrl+middle mouse button.

Thank You


sal: button1, button2 and button3 are more generic labels than “left”, “middle”, “right” because some left-handed users prefer to remap their mouse buttons (and some don’t). i used to think it was very important to use buttonN, but over time, as i see how many people simple fail to understand this, i get closer to leaving button remappers to their own devices. its quite unfortunate.


Well I’ve tried all 4 buttons (left, right, center, side) with Ctrl and no joy (i.e. no message pops up). Mouse mapping is is the Apple default. I’m on a Mac Pro running OSX 10.6.4. and Ardour V2.8.11. Is there any other way to do this?


Chances are you don’t have Generic MIDI Control enabled then. You will need a three button mouse, then CTRL+MIDDLE Mouse Button should work fine. It certainly does here last I checked on a nearly identical system.



You were right. For some reason, ‘Generic’ was no longer checked (Mackie was). Now the "Operate Controller Now’ message appears, but it it doesn’t ‘see’ Slider 4 movement. Currently Slider 1 is assigned to track 1, Slider 2 to track 2 and Slider 3 to track 3. These work properly.

Very strange, I tried all 4 sliders and it didn’t respond to any of them By that I mean I brought up the ‘Operate Controller Now’ message and then tried moving each slider… nothing happened. Seems I am still missing something. How is it possible that Ardour ‘sees’ the MC Control (i.e. hardware) sliders and will sync them to the onscreen track sliders, but not the onscreen master slider?

Hi everybody,
I have the same problem. I use a Faderfox PC4 midi controller. In Qjackctrl, MIDI tab, I have connected Faderox PC4 midi to Ardour “Midi control In”. In Ardour 4.7, Generic MIDI control ( Options -> Control Surfaces -> Generic MIDI) is activated. My device is well recognized by the software and selected in “Incoming MIDI on” field. However the window “Operate Controller now” not appeared when I Ctrl-middleclick on whatever on-screen fader, plugin parameter control, button. I just obtain “Send CC to automate” when I right-click. I tried with different synths like Calf Monosynth or Foo YC 20 Organ. Would you have an idea about this issue?
Thanks for your help.