midi bindings problem

I have a problem with the control-middleclick.
I’ve read some instructions on the manual, and on topics on internet, but nothing happen when I follow everything.

Nothing happen when I want to bind a fader to my control surface. I control-middleclick on the fader, but there is no dialog-box to tell me to move the control…

I’ve 2 mice : one logitech performance mx ( wireless) and one labtec ( wired ).
I’ve tried with 2 computers, and two debian-based distros ( squeeze, and avlinux 5.0 ).
My version of ardour is : ardour 2.8.12 (built from revision 9675)

So I thing I’m doing something wrong but I don’t know what.

I enabled generic midi in the options, and have plugged my control surface ( korg nanokontrol ) to the control of ardour before operate, and also tried to save the session, and reopen it, without success.

Is there anyone to help me ?

Thanks by advance

Hello again.
Something is strange, coming back from lunch, I did exactly the same that I did many times before, and it worked. I closed the session, reopened it, but the option " generic midi " was disabled. So I’ve enabled again, and… it worked.
I don’t know what to think, hopping that I will not be surprised when the time will missing, or when I will try to show someone how great is the work of Paul Davis.
To do that, I was with avlinux live-dvd, I will now retry with my debian unstable and my opendaw-4.0.

Thanks anyway for this wonderful software that I use with pleasure since year 2004.

This isn’t the issue tracker(See the link above) so there is no need to mark it as ‘resolved’

However my suspicion is, but I haven’t had time to check, is that the visual feedback on whether or not Generic MIDI is enabled gets out of sync with what is actually happening. So it will show enabled when it isn’t, and if you select it again, the protocol will become enabled but will show disabled.