Hello! Some days ago I was asking here if there was a way to play midi with the electric guitar. After reading the answers I decided to buy a cheap midi keyboard. It works fine when I create a new midi track (I managed to connect it… but ONLY when a-reasonable synth or Calf Organ etc. are selected)

I would like to know how to play the keyboard with a plugin like Vitalium. Thanks for reading this.

I just installed the Vitalium LV2 from the KXStudio site, started up Ardour, had the Plugin Manager do an update to make sure it’s visible, closed Ardour and re-opened it, successfully created a midi track with Vitalium, and connected my Korg microKey to it in qjackctl.

So where does your issue show up?

Hi thanks for the reply, well it’s maybe because I am playing on ALSA, without jack connection? If I would try to open a midi track in Jack projects, may I install some additional packages? Something like a2jmidid? (I searched right now for that name).

Thanks again

You do not need JACK. Using the ALSA backend is our recommendation for most users. What is the actual problem you are having?

Hi, @ardourwlk side question…

Just curious was Vitalium not already in AV Linux without being separately installed? I usually include the Vitalium VST3 Plugin as part of the DISTRHO ports…

The subject is about the LV2 plugin. Any reason why AVLinux does not include it?

LV2 plugins are unconditionally scanned at application start. The plugin Manager is only needed for VST and AU plugins.

@GMaq Glen, not sure why, but I could hazard a guess. You won’t recall, but I am on MX-21 original, and at some point, you switched from giganto-VST-inclusive package to separate packages, and so I believe that when I added in the Blonde Bop kit, that removed a bunch of stuff, and I probably didn’t go back and re-install vitalium. Caveat, I’ve never tried vitalium before today, so I can’t say if it was there from day 1.

re: VST3 - I’d imagine the same above. All I can say is that when I went into the Plugin Manager, there were no entries for vitalium, so I googled and got the one from the KX folks.

@x42 I had forgotten that the LV2 was automagically found. I did the restart because I did not give the full story… I actually had an (existing) Ardour session open (paid 7.5), to see if vitalium showed up (prior to installation). I saw it was not showing up, so I acquired the package and installed it, ran the plugin manager in that still-running session, saw it was there now, and created a midi track with vitalium, but it created the track without the plugin for some reason. I figured I might as well start fresh, so I closed Ardour, started a fresh session, and everything worked swimmingly.

To Paul’s point, where are you having the problem?

When you create the midi track, does vitalium show up as an option or not? That sounds like a good starting point.

And I guess I am assuming that you are doing this all within Ardour. If not, well, that’s a different story.

SORRY all goes well, I was as a noob inserting a midi/audio track but instead now i ve inserted a midi track with vitalium and all goes well… Thanks to Aaron Paul Robin


The distrho-ports build duplicate as LV2, VST2 and VST3 and ISO real estate is valuable so where applicable I provide the VSTs only on the ISO because they are compatible with all DAWs since some folks will install Waveform or Bitwig on AVL and then everything just works across the board. I do package the LV2 versions as an optional download though. Of course other included Plugins that are only available as LV2 are included as LV2.

Do you need JACK if you are using other audio programs outside of Ardour at the same time?

Also, Hello from Bo_Diddly from unfa’s discord!

Depends on what you mean by ‘using other audio programs’.

If you are talking about software that uses the sound card, no not necessarily. If you are talking about standalone audio programs that as part of your workflow you have audio routed to/from Ardour from those software then the answer is likely yes (Depends on what OS but Jack is a possible solution on any OS, and likely the answer on Linux)


Just as an FYI, I am not asking for me specifically. I use Pipewire and am perfectly happy with it.

I am asking this for others because I help a lot of people with Linux Audio issues and this question came up and I still don’t know the exact answer to it.

It is my understanding that ALSA is not an audio server, so when a program accesses it directly, that locks out all other programs, ie it doesn’t share resources like Jack, Pulse and Pipewire do.

You’re correct.

ALSA is the lowest level in the Linux audio stack.
Any program that uses it directly will have sole ownership of the sound card until the program exits.
So if you’re using Ardour with the ALSA backend you can’t play YouTube videos in your browser or listen to Spotify at the same time.

JACK, Pulse or PipeWire sit on top of ALSA and act, among other things, as an audio stream mixer.
So if all your programs use, say, PipeWire they can all use the sound card simultaneously.


To clarify and because this concept is bubbling around in other threads…

For many using Ardour with ALSA and giving Ardour ownership of the Audio hardware is not looked at as a limitation. It is looked at as a preferable shortened distance between point A and point B for getting to work with less variables and without distractions. PipeWire, PulseAudio JACK all open some doors with varying degrees of compromise along the way but there are only merits to any of them if they serve your needs at the time…


This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.