MIDI and loop ranges

(Linux, built from master a few days ago.)

When I am playing a loop, if the “end loop” marker occurs in the middle of a long note on a MIDI track, then that note keeps playing over the start of the loop, until that note gets played again.

Is there any way to force a “note off” event to be added for all “open” midi notes before returning to the start of a loop?

Do not use git-master at this point in time, unless you have very good reason. There are lot more open ends, looping is pretty much broken at this point in time. Also keep in mind that Ardour6-pre/git session-format is not frozen. Sessions created today may or may not load tomorrow. Stay with 5.12 for any work, except for development of Ardour, until Ardour 6.0 is released.

from Ardour-Users Announcement

Running directly from the source-tree will skip the warning (we assume you know what you are doing), but otherwise starting Ardour6-pre shows a dialog:

Welcome to this pre-release build of Ardour There are still several issues and bugs to be worked on, as well as general workflow improvements, before this can be considered release software. So, a few guidelines:

  1. Please do NOT use this software with the expectation that it is stable or reliable though it may be so, depending on your workflow.
  2. Please wait for a helpful writeup of new features.
  3. Please do NOT use the forums at ardour.org to report issues.
  4. Please do NOT file bugs for this alpha-development versions at this point in time.
    There is no bug triaging before the initial development concludes and reporting issue for incomplete, ongoing work-in-progress is mostly useless.
  5. Please DO join us on IRC for real time discussions about Ardour. You can get there directly from within the program via the Help->Chat menu option.
  6. Please DO submit patches for issues after discussing them on IRC.

Unfortunately a bug in 5.12 (as per my previous post) means I can’t do any work there either. This is a trifling issue for me in comparison, so I’ll take your warning on board, but continue as I am.

I’ll make sure I have backups (including exporting to stems) when I do upgrade.

Haha, you win. The bleeding edge version compiled from master crashes on punching in. So I can’t really use it either.

But large numbers of MIDI channels and exporting to stems works, so I can export my MIDI channels to stems from the bleeding edge version, then import those stems into the session in 5.12. Then I can continue working in 5.12 without being bothered by the MIDI bug… I think I’ve got this. :smiley: