midi - all notes off


When working with midi in ardour3 midi notes drone on anytime the piece of music is stopped. Is there a way to send a midi “all-notes-off” message when the transport is stopped?



the MIDI panic button is at the upper left of the transport bar.


I’ve seen it but it doesn’t work. Even if it did, it’d be nice as well if it could linked to transport-stop.

(a) it would be a very bad idea to link this to transport stop
(b) it works fine here for me. i regularly use it to silence external synths and devices with sustain enabled. i am not sure i’ve tried it with internal synths though - that could be a different issue.

@Paul, ccee


In Ubuntu Studio 16 / Ardour 4.6, MIDI notes are still left on after pressing stop. Panic button does nothing in this situation. So far the only way is to turn off the hardware synth(s). I have USB MIDI adapter. Playing in/out is fine, like playing keyboard into Ardour -> routed out to synths.
I have not configured JACK currently, in the beginning I started ALSA. Everything seems fine, exept for the “no note off at stop”.

Please file a bug report and attach a session (preferably minimal) that demonstrates the problem.

Well also, make sure you test in Ardour 4.7, even the free version should allow you to test this.


Today I thought that what if there is something left over from previous versions, so I completely removed all ardour-related stuff, updated all packages and then installed Ardour4 again. Could be that something was changed, at least I see the LEDs blink in my synths when I press Panic. Strange thing is that the notes playing are not turned off. Otherwise (on stop/play) the notes are usually turned off when resuming playback and the note off is reached, but not always -> stuck note(s). I’m using Sound Blaster Platinum (with Live Drive II) for audio, but MIDI using separate USB MIDI. The Live Drive MIDI output is just broken, it sounds like it’s missing bits or complete messages, notes may play briefly at note off. I recall reading there can be problems with classic hardware.

Could the non-pro nature of the sound card affect buffering etc. so the USB MIDI is broken as well? It behaves nicely, until I press stop. Even muting the MIDI track seemed to work properly for a while! When stopping, it’s like the MIDI queue stops as well… Hard to guess without seeing what goes out. I will try 4.7 and be happy to pay something for it if it fixes my problem :slight_smile: I’m just beginning with DAWs (hopefully Ardour alone will do because it looks and feels delicous!). Long time ago I tried Logic Audio Platinum, but I’m a tracker man. jeskola buzz tracker is my main tool, and it’s great - if you don’t need live MIDI gear.

My deepest respect for all you developing and/or helping the users!

Can’t run the …4.7.0.run! What now… “Command not found”

Nevermind… ./ and chmod may be required… finetuning my linux skills, sorry!

I did the test with the same session and 4.7. The behaviour is identical. MIDI channel mute usually works, sometimes a note may be stuck. Stop leaves notes on.

The installer warned me that I have cpu frequency scaling. I will change the governor, already found some instructions.

btw, the Ardoud installation instructions didn’t say anything about chmod or execution permission. Surely, a terminal user shoud run ll (ell-ell) to see the permissions before trying to execute :slight_smile:

The instructions tell you exactly what do to:

cd /folder/where/you/saved/the/file /bin/sh ./.run

No chmod is required.

Ok, thanks. I belive you - I guess I didn’t type /bin/sh Well, chmod 777 was the alternative way.

I’m running performance governor now, both of the CPU cores are at max (2.0 GHz). Did not affect the problems.

I opened MIDI Tracer window for the MIDI track I’ve got in my test session. From the MIDI event log I can see:

  1. STOP does NOT send note off’s, or anything.
  2. Track MUTE sends Controller chn n 64 0 (n = 1…16, sustain pedal, off) and note off’s for the notes that had corresponding note on prior to pressing MUTE.

By toggling the MUTE on/off during play, sometimes, some notes are not turned off.

It’s baffling me why this doesn’t generally occur for other people. I will file a bug report, with the session, as requested before.

Another thing: really bizarre results I got from using my keyboard -> Ardour -> MIDI out. The controller messages are converted somehow to note on messages, and the same happens to pitch bend. Spooky dark ambient stuff!! Interesting, but not funny. Only glitches of the real pitch bend occur at times. I understand this can be something else than Ardour (I will have to verify it by using some other software to route MIDI in -> out).

gmidimon or even aseqdump …

I’m contributing to this issue reported by cyril: http://tracker.ardour.org/view.php?id=6882
gmidimon as soon as I have the time for it. Have to take video of it, how else could I show that I really pressed stop at some point. But the message log may be useful for debugging the channel mute issue. If a missing note off could be spotted. Need to keep it simple to minimize the number of events.